Has anyone got Flexget to run?


So I am trying to install Flexget. If i try flexget -v I just get a traceback error.

Has anyone managed to get flexget to run on OSMC? I am currently on a RPi B+

Thanks in advance!

Yes, on a rpi2. Just followed the instructions.
Could be a missing dependency…

same here, flexget + pi2, no problems at all

Yeah so i had to update sudo pip install --upgrade six>=1.9.0 and then it worked
Thanks :smiley:

1 Like

Hi, I have just installed the latest OSMC build (September Release) on a RaspBerry Pi 2. Everything went smoothly but I cannot get Flexget Installed.

I installed PIP upgrade six as mentioned but I still get errors when installing flexged:

running build_ext
building '_sass' extension
creating build/temp.linux-armv7l-2.7
creating build/temp.linux-armv7l-2.7/libsass
arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat -Werror=format-security -fPIC -I./libsass -I/usr/include/python2.7 -c libsass/error_handling.cpp -o build/temp.linux-armv7l-2.7/libsass/error_handling.o -c -O3 -fPIC -std=c++0x -Wall -Wno-parentheses
unable to execute 'arm-linux-gnueabihf-gcc': No such file or directory
error: Setup script exited with error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1

Does anyone have a solution for this? I am a newbie when it comes to linux, so I’d probably need some detailed steps.

Thanks in advance!

flexget is being silly here and is trying to be cross-compiled. Before you run that build step, try this:

export CC=/usr/bin/gcc
export CXX=/usr/bin/g++
export CROSS_COMPILE=/usr/bin


Unfortunately this did not help.

I get the following error:

osmc@osmc:~$ flexget -V
Traceback (most recent call last):
File “/usr/local/bin/flexget”, line 5, in
from pkg_resources import load_entry_point
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 2876, in
working_set = WorkingSet._build_master()
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 449, in _build_master
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 745, in require
needed = self.resolve(parse_requirements(requirements))
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 639, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pathlib

Does anyone has a clue how to solve this?