Hauppauge dualHD tuner missing after update

I have a Vero 4k+ with Hauppauge dualHD and PCTV461e tuners (connected via a powered USB3 hub). All was well until updating to the latest version today. Now the dualHD tuner is no longer recognised and there is an “Unsupported device” message in dmesg.

Logs at https://paste.osmc.tv/jupivocuqa

I see that in the /boot directory on the device there is not only the current kernel but the previous one as well. Assuming that this problem is a driver issue, is it possible to boot the Vero off the old kernel?


I can see what the issue is and will look in to this shortly.


I’ve had a look at this. This driver is backported to our kernel so extra care needs to be taken to maintain it, particularly as no one on the team has this adapter.

I’ve reinstated support for the adapter.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.



It took me a while to notice that the staging repo should be deb http://apt.osmc.tv bullseye-devel main not deb http://apt.osmc.tv buster-devel main but the fix installed correctly and my tuner is working again.

Many thanks.

Thanks for reminding me – I’ll update that canned response!

This works for me too, thanks for speedy fix.

Finally found some time to look into this issue just to find it already resolved :-). Works here perfectly as well after this fix. Thanks for such a great support.