Hauppauge WinTV-DualHD Dual Tuner support

Hi there!

First of all I would like to thank the OSMC team for such a wonderful job - I have used OSMC for barely two months and am rapidly rolling out OSMC for the rest of my TVs due to its stability and support.

I recently obtained a WinTV-dualHD tuner from Hauppauge as a means of integrating terrestrial TV (DVB-C) into the system permanently.

I was pleased to see that there was support for the tuner out of the box - I was quickly able to get the tuner up and working.

I understand that support for the tuner is still patchy and that only one tuner out of the two is currently supported. I also understand that on the LibreElec forums there have been user-submitted patches to enable both tuners.

May I find out if there are works in the way to enable both tuners for OSMC as well?

You haven’t mentioned what device you’re running OSMC on.

LE uses media build but we don’t, so patches aren’t appropriate.

You may find the 4.14 kernel for Pi beneficial


My bad!

I am running OSMC on the Raspberry Pi 3 - I have upgraded to the testing 4.14 build; while it runs stable for me, the second tuner still does not show up - the tuner is identical to the 01590 model listed on the LinuxTV wiki. Might this be a firmware issue?

Check the output of dmesg it should tell you correct firmware to use. There may be different versions of same firmware.

Thanks - I’ve tried most versions of the firmware but they all result in one tuner showing up - might firmware be the reason the second tuner doesn’t show up, or might there be something else?

So I stumbled across a patch which is supposed to add second tuner function; I’d like to test it out myself to confirm if it works.

Now I’ve tried compiling the kernel on my Rpi3 with the instructions here but always end up with errors during the patching of some unrelated drivers.

Is there a way I can compile the specific drivers for em28xx, apply the relevant patches and load them manually?


I’m quite happy to say that I found the em28xx-*.ko files that were generated during the failed build, manually replaced the drivers in 4.14.15 and rebooted - the second tuner is now recognised so I’m quite happy to report that it all works…

Perhaps @sam_nazarko might consider adding the patch to the next build?

Kind regards

Well - no news from Sam but I guess I’ll be happy to provide the generated drivers if you need them - just drop me a message :slight_smile:

For now my drivers are compiled from 4.14.15…

I’m happy to accept a PR for this