Hauppauge WinTV-Duet Dual DVB-T Receiver

#1

Hi all,

I’m currently running OSMC on a Pi2 with a Hauppauge WinTV-Duet Dual DVB-T Receiver, and to get it to work, I have to do the following:

cd /lib/firmware
sudo wget http://linuxtv.org/downloads/firmware/dvb-usb-dib0700-1.20.fw

sudo nano /etc/modprobe.d/options.conf

options dvb_usb disable-rc-polling=1
options dvb_usb_dib0700 force_lna_activation=1

At which point it works great - my question is, will the same work if I move over to a Vero 4K(+) or will my tuner not be supported?

Best,

Colin

#2

Can you tell us the VID/PID of the device?

#3

FYI: Hauppauge wintv dualhd on Vero 4k+ - just one tuner

#4

He might not even get one tuner to work.
Hauppage internals often vary; even if they keep the same product name.

lsusb would allow us to see if the device is similar.

#5

Hi Sam,
The device is Bus 001 Device 006: ID 2040:5200 Hauppauge
On my RPi, both tuners function - it’s much older than the HD capable dual tuner that Hauppauge now manufacture.
Thanks!
Colin

#6

Any confirmation on this? I don’t want to break my currently working setup whilst stepping up to another device…

#7

Not sure. I will be updating DVB drivers to 4.21 soon; so things should work well then.

Just keep an eye on this thread

1 Like
#8

I’ve decided to take the risk anyway; I can’t see why it should stop working as it does at the moment. I’m assuming that you can SSH into a Vero in the same fashion that you do with an RPi! If I get to it before you do, I’ll let you know :slight_smile:

#9

So… The device appears to TVHeadEnd once the firmware is loaded as above, but it fails to scan on the Vero 4K+ after adding the relevant muxes. On the Pi I had this behaviour until I added the /etc/modprobe.d/options.conf - is this ignored on the Vero, or do I need to make the alterations elsewhere? Happy to perform any requested tests etc!

#10

It should be the same.
What changes did you need to make?

Sam

#11

I had to add these lines (which are the only ones in there now:

#12

Have you tried them on Vero? This is unclear

#13

I’ve done exactly as I would do on an RPi (that works). On the Vero, scans don’t start - they all immediately go to PEND and don’t progress. I’ve added the firmware for the stick (as it’s missing - this is the case on all Linux distros by default), and added the necessary lines to the modprobe.d conf file.

It could be kernel related, it’s rather old on the Vero. I found reference to a minimum of 4.10 but can’t be sure about that as it was in French!

#14

Ok — might be an idea to wait for the DVB updates for now

Sam

#15

Just so that this issue is a little better annotated; once the firmware and modprobe.d changes are made, both of the tuners appear on the Vero, but fail to scan the muxes.

Annotation%202019-03-12%20160700

The same stick plugged into (any) of my Pi’s 1/2/3 running OSMC with the same alterations and configuration, scan and discover upwards of 200 channels in total.

#16

Thanks for the data point.
When v18 is out of the door, I’ll look at moving to the 4.21 DVB stack.

Sam

#17

I decided to put my tuner on one of the Pi’s (I’m using 3B+'s) elsewhere in the house to get some TV going, and with current builds of OSMC, it has the exact same behaviour as on my Vero 4K+, in that it fails to scan muxes.

It used to work on my older builds when I was running OSMC on my 2B, and up until recently by upgrading all the way to the December 2018 build. I first installed that Pi some 2-3 years ago, so no idea what build it began on. Is there a dependency missing somewhere?

#18

Hard to speculate as in 2-3 years many things have changed.
I suggest to check firmwares and also read up on your exact version of the stick on Linux TV

#19

The instructions for my stick are the same on Linux TV as they were when I bought the stick 7-8 years ago. Add firmware by downloading it to the relevant area, and make changes to modprobe.d, so that’s not really a very helpful suggestion. I’d documented that above.

#20

Looking back, the firmware was added by Sam in 2017; and as late as May last year, I helped someone else with a similar issue: Hauppauge Nova-TD - Muxes scan FAIL

However this now doesn’t correct the issue on a clean install; although the Pi3+ install of OSMC had the firmware present in /lib/firmware before I attempted to download it, but the Vero 4K+ install didn’t. Neither had an options.conf file in /etc/modprobe.d

“sudo systemctl status tvheadend.service” returns:

Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2019-04-24 06:52:59 BST; 1h 55min ago
Process: 569 ExecStart=/usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video (code=exited, status=0/SUCCESS)
Process: 402 ExecStartPre=/bin/sleep 10 (code=exited, status=0/SUCCESS)
Main PID: 571 (tvheadend)
CGroup: /system.slice/tvheadend.service
`-571 /usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video

Apr 24 06:57:22 OSMC_Bedroom1 tvheadend[571]: mpegts: 762MHz in DVB-T Network - tuning on DiBcom 7000PC #1 : DVB-T #0
Apr 24 06:57:22 OSMC_Bedroom1 tvheadend[571]: linuxdvb: DiBcom 7000PC #1 : DVB-T #0 - failed to tune [e=Invalid argument]
Apr 24 06:57:22 OSMC_Bedroom1 tvheadend[571]: mpegts: 746MHz in DVB-T Network - tuning on DiBcom 7000PC #1 : DVB-T #0
Apr 24 06:57:22 OSMC_Bedroom1 tvheadend[571]: subscription: 0009: “scan” subscribing to mux “746MHz”, weight: 6, adapter: “DiBcom 7000PC #1 : DVB-T #0”, network: “DVB-T Network”
Apr 24 06:57:22 OSMC_Bedroom1 tvheadend[571]: mpegts: 706MHz in DVB-T Network - tuning on DiBcom 7000PC #0 : DVB-T #0
Apr 24 06:57:22 OSMC_Bedroom1 tvheadend[571]: subscription: 000A: “scan” subscribing to mux “706MHz”, weight: 6, adapter: “DiBcom 7000PC #0 : DVB-T #0”, network: “DVB-T Network”
Apr 24 06:57:27 OSMC_Bedroom1 tvheadend[571]: mpegts: 706MHz in DVB-T Network - scan no data, failed
Apr 24 06:57:27 OSMC_Bedroom1 tvheadend[571]: subscription: 000A: “scan” unsubscribing
Apr 24 06:57:27 OSMC_Bedroom1 tvheadend[571]: mpegts: 746MHz in DVB-T Network - scan no data, failed
Apr 24 06:57:27 OSMC_Bedroom1 tvheadend[571]: subscription: 0009: “scan” unsubscribing

“dvb-fe-tool -g” returns:

FREQUENCY = 706000000
MODULATION = QPSK
BANDWIDTH_HZ = 8000000
INVERSION = AUTO
CODE_RATE_HP = 1/2
CODE_RATE_LP = 1/2
GUARD_INTERVAL = 1/32
TRANSMISSION_MODE = 2K
HIERARCHY = NONE
DELIVERY_SYSTEM = DVBT

So it is locking onto a correct mux. Is there somewhere I can get an early 2017 image of OSMC? I’m tempted to try an old install and then upgrade again to see if I can get it going that way. Building TVHeadEnd manually on a clean new install of Raspbian with the firmware and modprobe options alterations results in a working configuration - so the issue is definitely related to the OSMC distro.