Having issues with initial osmc install

Hi,
Forgive me as I am incredibly new to this. I was looking into Kodi when I stumbled upon instructions to load it onto an apple tv. I pulled out my generation 1 and found info on osmc. I did a USB install and it installs successfully then loads the blue osmc screen, flashes black then flashes purple and then shuts off. I am at a loss of what to do. I’ve tried redoing it several times and even tried from an hdd install and it does the exact same thing so now I can’t even use my apple tv for its native function. Am I missing a step?? Did I do something wrong? Please help me before I throw my atv over the balcony of my apartment. Thank you.

You may need to configure Xorg.conf. It would help if you explain how your aTV is connected to the TV.

I have the atv connected through an hdmi cable :slight_smile:

Some video information is here: https://osmc.tv/wiki/apple-tv/frequently-asked-questions/. You might need to SSH in and edit Xorg.conf so it works for your TV.

Sam

Thank you very much for the help and the quick responses! Is there an explanation of sshing in to the atv anywhere? Do I need to get separate software? I got a little ambitious with this project hahan

Edit. Or do I ssh into the img and change it that way and reinstall?

https://osmc.tv/wiki/general/accessing-the-command-line/

Thank you thank you! So it would seem that because the tv I’m trying to connect it to is 720 display that it isn’t booting up correctly? I need to ssh into the device and change the xorg to the right configurations. Assuming this info is correct and that I understand what I’m talking about, since I have osmc installed on the atv by hdd, if I plug it into a 1080i tv as is through hdmi would it boot up? Because my problem now is, I’m not exactly sure how to get the ip address of the atv because it crashes on boot up since installing osmc hdd.

720p and interlaced modes require editing Xorg.conf. Been a while since I did this, but you do need to edit this file. Some other users may be able to help.

You can do it via keyboard too (press Esc when you see sad face), or check IP via your router.

Sam

I tried using Fing to find the ip, but I think because it crashes so soon it doesn’t connect so the app never shows the atv ip on the list. A sad face hasn’t shown up at any point in the process, the atv seems almost like it’s rebooting right after the osmc screen and then just never comes back on. Plus I don’t have a keyboard (I’m assuming you mean one i can plug in, I just have my macbook). I’m thinking my only option is to try a USB stick factory reset and start from square 1? I’m kicking myself for not writing the ip address down in the beginning.

Ps, again really appreciative of all the help!!! :blush:

Something isn’t quite right there. SSH is an independent daemon, so should work even if Kodi doesn’t start. If you can grab a keyboard and try and mash ESC until something shows up, you may be able to log in with osmc:osmc.

You can always try a USB install with the latest version from the site.

No problem

This may be unhelpful, but I have a similar issue on my RPi 3. On boot up, I get the OSMC splash screen then black. If I unplug the HDMI cable and replug it in, the screen comes up as it should. Have you tried this? It might help.

Completely different hardware, so not likely to be the same issue at all.