Having Problems With OSMC

Hey Guys!,

Well, I had just gotten the Raspberry Pi 2 Model B, and I really love it. So I had ran an owncloud server on it for a couple of days just to test network speed, and it was good!.

So now I had formatted the SD card, and got a build of OSMC. Everything was good upto the OSMC installer saying installation complete at the Raspberry Pi 2.

After that, the Monitor loses the signal and the Raspberry Pi doesn’t output a signal. I had noticed the Raspberry Pi to have the Red Light On and the Green Light flashing in long intervals.


Can you ssh into it? The green light flashing indicates SD access which normally is a good sign of it being alive.

I would recommend running

tvservice -s

and posting the output


I can still ssh into it right? I had formatted my sd card and put OSMC on it

Yes that’s correct


state 0x12000a [HDMI DMT (4) RGB full 4:3], 640x480 @ 60.00Hz, progressive

That is what I got. I am using a HDMI to DVI connector

The OSMC setup screen just came up,then it went black when I pressed a key on the keyboard, it went black

Yes, I can ssh into it.

Looks like your monitor is not reporting any EDID data, so the Pi tries to boot in a default 640x480 resolution.

Also check the output of the following two commands to confirm this:

tvservice -m CEA
tvservice -m DMT

If neither of these provide any output then either the cable is faulty or the monitor is not providing any EDID data. What kind of monitor is it ? Have you tried unplugging the monitor from the power for 30 seconds to reset it, turn it back on, then boot your Pi ?

Can you try a different cable ?

It’s possible to force a particular resolution with the right options in config.txt if you don’t have any other choice.

I found out what was wrong, the cable was broken or not working properly. I used a HDMI to HDMI connector on our TV (Where the RasPi was going to go eventually) and it had worked!