Having trouble installing OSMC

they are in the release image

Yeah, like grahamh said, they were included in the image config file.

I wish I was a Linux expert to identify the problem, I know so little to figure out where I could be screwing up.

One thing seems sure is that the memory card bootloader is being read, because I have DietPi installed on pen drive which is attached to the USB port. If pi wasn’t picking anything up on MC, it would’ve booted straight into DietPi which it doesn’t. And my mouse and keyboard get powered up too.

There is a filesystem.tar.xz file which I assume contains the stuff that’s usually in second ext4 partition. Can I do the partitioning myself and extract that file into the second ext4 partition and keep these boot files in fat32 first partition? Can that work?

It may be worth trying it with the gpu_mem=16 removed. The RPi documentation says that minimum memory disables some features but does not state if composite output is one of them.

I have no idea about making the second partition yourself.

Have your tried with the USB drive removed? It may be confusing the installer.

Just did that, but this time even the mouse didn’t power up. Same green light blinking loop happened that I’ve mentioned earlier.

I did many times, but that doesn’t change anything.

Even if there’s no composite output, it should at least create a new partition on the memory card. Which happens automatically from what I’ve seen in YouTube videos.

I’ve checked md5sum of the zip file and it matches with the one online so my download isn’t corrupted.

Are new images of OSMC capable of outputting composite video on first boot without installation? I am doing things exactly as listed in many tutorials, then why it’s not working?

There should be an “install.log” on the boot partition. Check what is recorded in there.

There’s no install.log file in boot partition. Indicator of install not being initiated?

Can you provide your cmdline.txt file too along with your list of files in boot/.

I’ve created another ext4 partition and extracted the contents of filesystem. tar.xz (which came along with the OSMC image) there. Now all the usual folders of a Linux distro are there.

But I have a question, I thought linux mounted the first fat32 partition on /boot but there was already a /boot folder in filesystem.tar.xz filled with kernel, bootcode.bin, start_x.elf etc along with some extra vmlinux files. So which one should I keep in my first boot partition?

In the working system, /boot is a mount point for /dev/mmcblk0p1. The contents should be the same but I don’t know what the installer does. cmdline.txt and /boot:

osmc@pi3bp:/boot$ cat cmdline.txt
root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2

osmc@pi3bp:/boot$ ls -l
total 24175
-rwxr-xr-x 1 root root    1494 Oct 27  2018 LICENCE.broadcom
-rwxr-xr-x 1 root root 2063640 Dec 12  2018 System.map-4.14.78-4-osmc
-rwxr-xr-x 1 root root   23311 Dec 12  2018 bcm2708-rpi-0-w.dtb
-rwxr-xr-x 1 root root   23067 Dec 12  2018 bcm2708-rpi-b-plus.dtb
-rwxr-xr-x 1 root root   22808 Dec 12  2018 bcm2708-rpi-b.dtb
-rwxr-xr-x 1 root root   22585 Dec 12  2018 bcm2708-rpi-cm.dtb
-rwxr-xr-x 1 root root   24111 Dec 12  2018 bcm2709-rpi-2-b.dtb
-rwxr-xr-x 1 root root   25570 Dec 12  2018 bcm2710-rpi-3-b-plus.dtb
-rwxr-xr-x 1 root root   25307 Dec 12  2018 bcm2710-rpi-3-b.dtb
-rwxr-xr-x 1 root root   24083 Dec 12  2018 bcm2710-rpi-cm3.dtb
-rwxr-xr-x 1 root root   17629 Dec 12  2018 bcm2835-rpi-a-plus.dtb
-rwxr-xr-x 1 root root   17513 Dec 12  2018 bcm2835-rpi-a.dtb
-rwxr-xr-x 1 root root   17916 Dec 12  2018 bcm2835-rpi-b-plus.dtb
-rwxr-xr-x 1 root root   17792 Dec 12  2018 bcm2835-rpi-b-rev2.dtb
-rwxr-xr-x 1 root root   17659 Dec 12  2018 bcm2835-rpi-b.dtb
-rwxr-xr-x 1 root root   17822 Dec 12  2018 bcm2835-rpi-zero-w.dtb
-rwxr-xr-x 1 root root   17617 Dec 12  2018 bcm2835-rpi-zero.dtb
-rwxr-xr-x 1 root root   18448 Dec 12  2018 bcm2836-rpi-2-b.dtb
-rwxr-xr-x 1 root root   18266 Dec 12  2018 bcm2837-rpi-3-b.dtb
-rwxr-xr-x 1 root root   52116 Oct 27  2018 bootcode.bin
-rwxr-xr-x 1 root root      63 Jan  1  1980 cmdline.txt
-rwxr-xr-x 1 root root  138397 Dec 12  2018 config-4.14.78-4-osmc
-rwxr-xr-x 1 root root     129 Jan  1 10:52 config.txt
drwxr-xr-x 3 root root    2560 Jan 20  2019 dtb-4.14.78-4-osmc
-rwxr-xr-x 1 root root    9891 Oct 27  2018 fixup_x.dat
-rwxr-xr-x 1 root root    2260 Jan  1  1980 install.log
-rwxr-xr-x 1 root root 8341128 Jan 20  2019 kernel.img
drwxr-xr-x 2 root root   15360 Jan 20  2019 overlays
-rwxr-xr-x 1 root root 4057636 Oct 27  2018 start_x.elf
-rwxr-xr-x 1 root root 1369219 Feb 23  2019 uploadlog.txt
-rwxr-xr-x 1 root root 8341128 Dec 12  2018 vmlinuz-4.14.78-4-osmc

Also check /etc/fstab is present and correct.

osmc@pi3bp:/etc$ cat fstab
/dev/mmcblk0p1  /boot    vfat     defaults,noatime,noauto,x-systemd.automount    0   0
# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/mmcblk0p2  /    ext4      defaults,noatime    0   0

Thanks a lot man.

Ok so I copied /boot from filesystem.tar.xz to boot partition and made a config.txt with your settings. I turned the pi on and screen instantly went to black from blue (default of my TV), so finally pi is outputting something. So it wasn’t the faulty cables or my method of copying files, the installer doesn’t seem to be compatible with RCA output.

Now that installer probably does whole lot of settings that I am not sure we can figure even half of them out. But hey we can try.

Very strange. TBH not having a display with HDMI available (even from a friend) is rare these days but maybe we could have a look at what’s happening there.

When i was extracting files from filesystem.tar.xz to the partition, very often the partition would go read-only, so i had to remount the partition and extract again. To avoid copying old files again i used the --keep-old-files tag on that tar command.

So now it could be that the file’s name was created but before it could be copied completely, the partition froze. But when next time the extraction began, tar skipped over it because there was already a file with same name. I’ll try to fix that first.

And I don’t have any friends.

Maybe the root issue is a duff SD card then.

1 Like

it is, that’s what i was gonna explain in the end. It’s all probably due to my shitty card. When i was creating ext4 filesystem on partition, it would never finish. I tried different tools but the same result.

In the end i excluded 500MB space to avoid that problem. Tha’ts probably why installer was unable to create any partition on memory card.

I am sorry for making all of you find solution to this problem and asking so many questions. The only positive thing i got out of this is that a learned a little about boot procedures of linux and raspberry pi.

Thanks everyone for all your help.

So how should I go about launching Kodi now?

There’s just a black screen.

Get a new SD card.

I’d say to stop trying with this SD card since you know it’s problematic and use a new card. Even if you get it working, you are just inviting problems down the road.

If you can SSH in now,

systemctl start mediacenter

would start Kodi.

Keyboard and mouse aren’t powering up. I am giving up on this.

Maybe I’ll try again when I get a new card.

So i - copied OSMC boot files to boot - copied DietPi boot files to boot partition. Didn’t overwrite the OSMC ones though. Replaced the root option in cmdline.txt to point to OSMC files.

Turned the pi on and the usual things that happen in Linux like starting daemons etc started happening. Some daemons didn’t manage to start. A blue screen with a sad face appeared.

A start Job is running for Set Time using HTTP query (No Limit)

displays above the screen. The blue screen goes off after regular intervals and turns on again. After some time that message disappears but the sad face blue screen keeps going off and on.

Atleaast now the os is booting, even if it’s corrupted.

When I press alt+F3 something to open alternative console, it asks for login. I put “osmc” for both username and password. It asks the same again. Sooner or later that sad face appears again.

stopped geyyy on tty2
started getty on tty2
removed slice user Slice of osmc
Started Set Time using HTTP query
Starting LSB: Start NPT daemon
Reached target Multi-User System
Reached target Graphical Interface

This is from tty1 after a press CTRL+c on boot, that makes sad face dissapear.

Now on tty2 I can login, but each time I enter correct credentials it shows a bunch of text (Debian GNU linux something) for a portion of a second and then asks to login again.