HD Audio and Pioneer AVR

I have the Vero 4K+ connected via HDMI to a Pioneer VSX-1020 AVR and I’m using pass-through (all audio settings below). The receiver is set to Pure Direct, but I’ve had the same results when it’s set to Auto Surround. I’m having issues with both DTS-HD MA and TrueHD.

I’ve tried 2 different HDMI cables. I have tried all 3 Output Configurations. Best Match and Optimized will sometimes give me HD audio, but sometimes it won’t. If it does and I hit pause, I may get no audio when I resume or I may continue getting HD audio. Fixed gives me working audio using PCM Direct, as my AVR calls it, but it often starts out at extremely low volume. If I pause and resume, the audio volume returns to “normal”.

For the debug, I played the same file using Best Match, then Optimized, then Fixed. For the first two, I paused and resumed until I acheived DTS-HD MA and then lost it. For Fixed, I just paused and resumed a few times; audio began low, but after pausing, returned to “normal” level.

Log is at https://paste.osmc.tv/sejecifecu

Here are my audio settings:

IMG_20200828_150816 IMG_20200828_150846 IMG_20200828_150902

set the number of channels to 2.0…should work then.

Thanks for the suggestion, but that didn’t have any impact. All 3 settings still do the exact same thing. I also tried a couple other speaker configurations without any impact, as well.

I have the same receiver being fed through a Hisense H9G (passthrough)
The only thing I have different than you is E-AC3 switched off. E-AC3 wasn’t even thought of when this receiver was made. You should then get a transcode option…enable it.
I have 2 channel selected (default passthrough setting)
I get full audio output with these settings…I’m using this cable…

Thanks for chiming in. I haven’t moved to a 4K TV yet, but glad you’ve got a similar setup, otherwise. I made the 3 Kodi changes you suggested:

  1. Disable Dolby Digital Plus (E-AC3) passthru
  2. Switch to 2.0 channels
  3. Enable Dolby Digital (AC3) transcoding

Sadly, this didn’t change anything, so I figured I’d give your cable a try. It should be here by Sunday and then we’ll see if it’s a cable causing the problem.

E-AC3 is Dolby Digital+, so the receiver reports that it is able to handle this.

For the settings please try

  • number channels 7.1 (whatever you connected to the receiver, let the receiver do the downmix to other speaker layout)
  • output config: Best Match (never ever use optimized, this keeps the previous layout and is in most cases wrong)
  • resample quality (I always use high but doesn’t matter for this issue)
  • keep audio device alive: always (I’ve seen TVs and receivers having timing issues with hdmi changes and this was then the solution; assume a similiar problem with your env.)
  • send low volume noise: enabled (see comment above)
  • Play GUI sound: Only when playback stopped (first set it to default, if all is working as expected try to deactive it if you want)
  • Allow passthrough: enabled with all kind of formats enabled as well since your receiver reports to be able to handle it.

Your connected TV is very limited in supported refresh rates and resolutions:

====================== Display Cap =================== g0gjk991
480p60hz
720p60hz
1080p24hz
1080i60hz
1080p60hz*
---------------------- Display Cap END --------------- g0gjk991

But give it a try to enable the setting at GUI->settings->player->adjust refresh rate with value on Start/Stop. This should send the original refresh rate of the video material if the TV supports the current rate and prevents transformations which could lead to visible skips/micro stutters.

Addition: The Pioneer VSX-1020 is meanwhile a 10 year old device … at least check whether you have latest/greatest firmware installed on it.

And make sure you have “Sync Playback to Display” disabled, otherwise passthrough will never work.

1 Like

Thanks, Jim. First, I couldn’t find any firmware updates for my AVR. :frowning:

Second, I tried all of those settings, exactly as described. When I first made the change, it appeared that everything was going to work because the file began playing back with DTS-HD MA, through many pause/play cycles. Then, I hit stop and turned off GUI sounds, thinking everything was fixed. However, I noticed the issue persisted randomly when playback started and an HD audio track was the default, or if, during playback, I switched from DTS to DTS-HD MA. It appears I no longer have an issue brought on by a play/pause cycle, though. No matter what combination of settings I’ve tried, the play/pause cycle has no effect at the moment.

In summary, here is what we have:

Adjust Display Refresh Rate: OFF, ON START/STOP, or ALWAYS
Upon playback start, DTS-MA HD status: Randomly works or no audio at all
Pause/Play cycle: No effect
Switch to DTS during playback: Always works
Switch back to DTS-HD MA: Sometimes begins, regardless of playback start result

Yep, that’s disabled.

I also have the new cable, suggested by @isolar801.

I’ve generated new logs for this current setup at https://paste.osmc.tv/ofifugaluz

The logs should show results for beginning playback, showing DTS-HD MA audio not working, switching to DTS, showing audio working, switching back to DTS-HD MA audio, showing audio not working, and then 3 more repeated switches between DTS and DTS-HD MA before the DTS-HD- MA began working.

Let me know if you want me to produce logs showing anything else.

I see a lot (!!!) of log entries like

2020-08-31 19:25:26.601 T:3264656096   DEBUG: Readrate 269000 is too low with 3425815 required

which means the throughput from your smb device is not not sufficient. Not sure whether this is the root cause of your inspected behaviour but definetly this is something I would correct at first.

Just for tests could you copy the used test video file(s) to a fast USB stick or better a self-powered hdd, connect it to the vero and try again with such local playback (using the audio settings as suggested above)?

I don’t see such an entry in the previous log file I created, so I’m wondering if there was a backup running at the time I ran this test. I don’t want to overreact and think I’ve got a major issue with my server array, so I think the local playback is a reasonable check. I have an external USB adapter I can use to connect and power a drive locally, so I’ll give that a shot and report back.

Besides the outstanding tests with a local storage, last idea which came to my mind is to try

GUI->Settings->Video->Lock HDMI HPD set to enabled

Thanks yet again, Jim. I attached a drive using a powered USB adapter, played a file back, and the same issue persisted, so it doesn’t appear to be a problem with throughput. I then tried Lock HDMI HPD set to enabled (and rebooted, as the setting states is required) and am still seeing the issue.

I know I’ve got a workaround (switching audio channels until it works), but I’m hoping we can figure out what’s causing this because I didn’t have this issue with my NUC running 18.7 under Windows. Any other ideas?

I assume you mean switching audio input sources on the receiver, right?
No, I’m running out of ideas. You proved that the receiver can process DTS-HD and TrueHD with another device (as last test I would try the same HDMI port with the Vero) … but it looks to be a kind timing issue of this old Pioneer device. With current Veros and OSMC those issues should all be gone since a long time; what’s left is that you try to research whether you have the latest/greatest firmware on the Pioneer (if a downloadable firmware exists anymore).

Just have had a quick look in the manual of the Pioneer VSX 1020: What happens when you have the situation of no sound and you use the receivers remote control, buttons “RECEIVER” and “SIGNAL SEL” and choose “HDMI” (or toogle between others but stay finally at “HDMI”)?

But other ideas are welcome.

My apologies for the poor communication there. I was afraid my wording might have made it confusing. ‘Channels’ was the wrong term to use. I should have said audio track. To avoid any further possibility of confusion, I mean that Kodi sees there are two embedded tracks, #1 being DTS-HD MA and #2 being regular DTS. Obviously, track 1 is always the default it tries to play. If it doesn’t work and I switch to audio track 2 (DTS) during playback, that will always play fine. If I then switch back to audio track 1 (DTS-HD MA), it may or may not begin playing that. If I switch back and forth enough times (usually 2-3, max), DTS-HD MA will inevitably kick in.

Signal Select doesn’t switch to anything at that point. When I press it, the receiver’s display just confirms what’s selected and nothing appears to change.

I’ll do a little more digging on the receiver’s firmware, but there’s nothing listed on Pioneer’s website.

I did some further searching and wound up on the avsforum. Someone was asking about firmware updates just last year 2019 and they saw the same thing I did, in that there isn’t one: https://www.avsforum.com/threads/the-official-pioneer-vsx-1020-k-owners-thread.1245449/post-58120446