HDD Disconnecting

Since last week, my HDD (2.5 portable plugged via powered USB HUB) has been malfunctioning. Since I had some errors in dmesg refering to it, I checked it in my Windows 10 computer. No fs errors, nor sectors nor anything.

Even then I just backed up and did a low level format. Then I put back my files and plugged it again on the hub and it just worked. But after some hours I lose access to it, like if it was unplugged. This get fixed by plugging it again or by rebooting the system. What can be causing this (I’m on Leia nightlies BTW)?

Thanks in advance!


Have you tried leaving connected to windows 10 PC, for a few hours and see if you can reproduce the issue?

It could be a failing drive or a power issue, so could also be a issue with the usb hub.

When it occurs again, on the commandline issue:

dmesg | paste-log

And post the given link again.

Thanks Tom.

I rebooted the Pi at the time I created the post, and it seems it still works. Will report as you say when it fails. Whatever happens I’m planing to clean install OSMC when the final Leia version arrives. I hope that fixes it if we can’t troubleshoot it before.

Here you have: https://paste.osmc.tv/cuforefuqo .
There are some errors, but as I said none happen when plugged on the Windows computer.


Looks like potentially like a failing disk, maybe worth trying it attached to a different usb powered hub.

Thanks Tom.