Hdhomerun drifting audio sync AND unable to update monthly OSMC updates

In December I purchased a raspberry pi 3 (upgraded from a pi2) , installed OSMC and purchased a hdhomerun connect duo, installed the Hdhomerun addon. It worked well for a few weeks…

BUT… since January, every time there is an OSMC monthly update, there is an error installing the update, I get an error saying that the update could not install and I should post the problem on this forum.

AND, very annoyingly the Hdhomerun audio sync gets broken, the audio sync starts drifting badly, unwatchable within 15 seconds.

I posted for help on the Silicon Dust forum but they responded that they have no control over Kodi sync issues.

According to My OSMC I’m still running the December 2018 version, but it’s now February 26 2019 so I think I’m at least 2 updates behind.

I tried using SSH & the command line to manually update. It seemed to work, but My OSMC says I’m still running the December version. AND the hdhomerun audio sync is still way off.

Interestingly about a week ago an update was pushed out & installed while I was using a different addon, I then switched over to Hdhomerun & the problem was fixed!

BUT, since the update (March update?) which again would not install, I’m back to the horrible audio sync issue.


That is the current stable version

1 Like

Ok, thanks. Any insight on why I am getting Hdhomerun audio sync issues? It’s been going on for a couple of months & is basically unwatchable like this.

Like I said, I was using another addons a week ago & a message came up that an update was installing, then completed. I switched over to hdhomerun for the heck of it & everything was great.

I fired up OSMC tonight, there was a message of a failed update like I described & I’m back to terrible audio sync again.

Any insight?


How about some logs?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Ok, thanks. Can’t do it now, I’ll try send it to you in 24 hours…

Hi again, here is my log:

https://paste.osmc.tv/ hoxolizifuk (note the space before “hoxolizifu”)

Hope I did it correctly & you can get the information from that link.

I followed the instructions after enabling debugging & after rebooting I just started the hdhomerun addon & let it run for about 3 minutes. Within 15 seconds the sync was noticibly drifting & after 3 minutes the picture was horribly late in relation to the audio.

Again, it worked very well in December but became problematic in January. A week ago after some kind of an update was pushed out the problem was fixed, sync was perfect & did not drift at all over the course of a few hours. A few days later (yesterday) there was an error message saying the latest update failed to install & I should report it on this forum, which I did after seeing the sync problem was back.

I’m using a pi3 with no real peripherals, just a Seagate USB drive for video files, & a wireless keyboard which requires a USB dongle.

I am running the hdmi signal through an hdmi switch and then an hdmi splitter to a few different tvs. I’m pretty sure they are not the problem as I do not have sync issues using any other addon or playing a video file from the Seagate drive. Also, like I said, everything worked perfectly for the first few weeks.

Thanks a lot for your help.

Sorry, I steered you wrong, there should be NO space before “hoxolizifu”

The correct link is:


Well, it seems I fixed the problem. Like I said, I have a few TV’s hooked up through an hdmi splitter. The 1080p TV wasn’t getting a signal but only when using OSMC (weird in itself because it was getting a signal in the past). So I checked the system display settings in OSMC which set, by default I guess, to “desktop”. I changed that to 1080 x 720p & voila - everything is working great now : sync is perfect & display signalon 1080p TV is working too.

Very happy now - thanks for sharing my OSMC pain.


1 Like

To possibly help others: what HDMI splitter do you have?

I run the pi3 through a AUKEY HDMI Switch, which switches between the pi, video Chromecast dongle, and blu ray player & the output of that goes to an OREI HD-104 1x4 4 Ports HDMI Powered Splitter, sending the signal to 4 TVs.

Works for me but somebody I’m sure could come up with a better way to go :blush: