HDMI-CEC not working any more

#1

Hi there.

I have a vero4k+.
When I first set it up a few weeks ago, I had it attached to the TV through a Pulse Eight HDMI-CEC adapter. This worked.

A week later, assuming I actually didn’t need the adapter, I disconnected it. No problem, I could still control my vero4k+ with the TV remote. Great !

This week, after it has been working fine for many weeks, suddenly the TV remote does not respond anymore and at booting vero, I get an error ‘failed to initialise CEC adapter Pulse Eight…’.

I tried disconnecting everything, powering off and finally, formatting the vero4k+ but without success.

What else can I try?

regards

#2

Can you try power everything off (TV, AVR etc) off at the mains for a minute?

Sam

#3

Hi Sam, this is one of the first things I tried before formatting.

regards

#4

Please upload some logs so we can see what the issue is

Can you also try another hdmi port on your display

Sam

#5

Changing hdmi port to no avail.

https://paste.osmc.tv/uvaharubam

#6

The log file is empty. try to reboot before uploading

#7

https://paste.osmc.tv/rivutehida

#8

Please enable debugging and upload logs again.
Also did you crosscheck that you didn’t disable any CEC settings on OSMC?

#9

Libcec is enabled by default and should be working by default, no?
I checked the plugin and it is enabled.
Here are the logs with debugging enabled: https://paste.osmc.tv/iwonugupij

#10

Yes it is enabled by default but doesn’t mean it can’t be disabled or misconfigured.
Check under Settings->System->Input->Peripherals->CEC Adapter

From your logs all looks normal, while there seems to be no CEC commands being recieved.

#11

I did check this and it is enabled.
I was looking into TV updates but the last update seems to be from 2 months ago when it was still working.

#12

After disabling, re-enabling, rebooting TV and osmc a bunch of times suddenly it worked. :face_with_monocle:

Remarkable: the status of the CEC adapter in osmc at one point changed to ‘unknown’ and after I rebooted it worked.

Very annoying, had to format my whole system and I still don’t know know whether it’s the TV or osmc (or both)