HDMI-CEC not working on Pi 3 B+

Hi. I’ve been using my Raspberry Pi 3 to watch twitch streams on my TV. It’s worked fine for over a year until a few months ago when CEC just stopped working.

I’ve tried: Turning off TV at mains for 10+ minutes Resetting TV to factory default settings Reinstalling OSMC Checking for updates, both on TV and OSMC Changing HDMI ports Changing HDMI cables

at the moment I’m just stumped. I’ve got over the solution by hooking up an old mouse but I have to walk over to the TV to use the mouse and it’s not the most practical nor elegant solution.

If anyone knows what is causing this issue, that’d be amazing.

Yes, it would be really amazing if we would know what is wrong by the information you have given.
Suggest to enable debugging. Reboot, switch input source on the TV from and away from OSMC and then upload logs.
It also would help if you tell us make/model of the TV.


Not related to CEC but the mouse isn’t your only option, you can use your smartphone as a remote control too by using one of the Kodi apps