HDMI-CEC not working (Sony Bravia)

#1

Vero 4K + user here, using latest OSMC which comes with libCEC 4.0.4 (firmware v5). I can’t get my Sony Bravia Z9D’s remote working - it was fine with my previous Raspberry Pi + LibreELEC. I’ve tried playing around with the settings (HDMI port number and physical address), without any improvement. My OSMC is connected (via a HDMI switch) to my Denon AVR-X3500H, so I changed the “Connected to HDMI device” option to “Amplifier / AVR device”. When I press the TV remote’s volume buttons, it changes the receiver’s volume, so something is working…

But typing dmesg | grep -i cec in the console returns zero matches. Does this mean something is not loading? I am currently using the Vero remote, does this disable CEC in some way?

I’ve uploaded a log here in case it’s of some use. OSMC remote isn’t bad but it would be nice to be able to type numbers in directly etc. Thanks for any advice!

#2

Test without the switch?

#3

I had to send CEC broadcast request commend from the TV itself, SONY, then the TV recognized all devices connected via Denon amp and now I’m able to control all without any issues.

#4

Yes, doesn’t work either unfortunately.

#5

You mean the “enable” option under Bravia Sync menu? This is something else that I tried but that didn’t work :unamused:

#6

First thing I would have tried would have been to shut down all devices, then actually remove power from them all by unplugging from mains, completely boot all devices in the chain with the Vero being booted only after all other devices are up and on the correct input.

#7

yes, had a look last night, it’s the Bravia sync option, once I hit this button TV starts search over HDMI for connected devices. Once it’s finished it lists all devices; 4 in my case. And all 4 are working sound including my vero box

#8

Thanks for the suggestion, I just tried that but of course it still didn’t work. I think this is more than a HDMI issue. Shouldn’t I be seeing something CEC-related in dmesg output?

#9

Are you using the same hdmi cables are you were with the Pi? Not all cables support CEC and I have heard of some cables that should support it just now working (or go bad so they stop working). I don’t think CEC is supported in a particularly robust manner. Also is there something out of the ordinary about your setup. Why are you using a switcher in the first place instead of switching in the AVR. Perhaps you have another device that is in conflict?

#10

Try another HDMI cable.

#11

So that I can run my Vero and (very occasionally) my Raspberry Pi, which handles 3D movies better…

#12

I’m using pretty high quality cables from Monoprice: http://www.monoprice.com/product?p_id=15428 so I can’t see how that would be an issue?

#13

Have you tried removing the Pi and switcher to see if it works without them? It seems plausible that your TV might be having issues with two different OSMC devices being connected at the same time.

As for the cables, I don’t think it really matters how trustworthy/expensive/whatever as they can still have flaws. I have had cables that work perfect on one device and have issues with another. They can be quite finicky. Swapping cables out to test is usually a good place to start even when you trust the cables and they don’t show a defect.

#14

Thanks. I just tried connecting my Vero directly to the AVR, using OSMC’s cable. It still didn’t work. :pensive: Isn’t that conclusive proof that maybe something is wrong on the software side? Is there a way I can re-init CEC from the command line?

#15

After you made the swap did you reboot the Vero (with the TV on)? If that doesn’t work then you could try connecting the hdmi directly to the TV (reboot the Vero after) and/or pull the power for the TV and AVR from the wall for a few minutes and try it again. I have a Denon AVR as well and I have had a couple times after brownouts where the receiver would stop working correctly until I gave it a hard reboot.

#16

I too have a Sony 4K LED LCD (XD93) and Denon AVR (X2300W).

I have a bunch of HDMI devices connected into the AVR (including a Vero 4K) with the TV connected to the AVR’s HDMI output via its ARC-enabled HDMI port, and have experienced CEC failures for some (and sometimes all) connected equipment a couple of times in the past.

In my case it was never Vero 4K, TV or indeed directly AVR-related and no manner of resetting settings on the TV, AVR or Vero helped in my case.

In each case I managed to narrow it down to my Samsung 4K BD player which was somehow grabbing and holding onto any CEC signals effectively blocking communication of other devices and stopping them from even being “seen” by the TV or AVR as being CEC-enabled or even as connected via HDMI (so they disappeared from the TV’s input selector and Home screen).

I ended up having to power off AND DISCONNECT (this was crucial) each HDMI device connected through the AVR in turn and hard power off both the AVR and TV to find the culprit. As soon as I temporarily powered off/removed the 4K BD player and powered the AVR/TV back up things magically started working when re-running the Enable/Bravia Sync feature once I’d re-connected/powered up everything else. Re-adding in the 4K BD player once I was happy other things were working has seemed to work fine henceforth as well…I suspect a bug in the HDMI/CEC implementation of that device…

#17

Thanks for your reply. I tried what you said: power down and disconnect everything else. Sadly, even then the TV remote wouldn’t work on the Vero. :sleepy:
The only possibly odd thing I see on my TV is under the “Bravia Sync device list” menu: it recognises both my AVR (as “Audio system”) and Kodi (as “Recorder 1”) under the same HDMI port. “Connected” only appears next to the Kodi device. Here is a picture: