HDMI CEC not working

Hi,

My remote stopped working recently and I don’t recall changing any setting. I’ve tried other solutions without success. I have an Sony AV Receiver STR-DN1040 that is connected to two Pi’s 3, a Chromecast, a Humax Set Top box and a Samsung TV Series 8.
Can you help me? What other info would you need besides the one below? My level is “expert” noob :slight_smile: so I can do somethings, but others, I will need some guidance

Config.txt

cat config.txt 
gpu_mem_1024=256  
disable_overscan=1
start_x=1  
disable_splash=1
dtoverlay=lirc-rpi  
gpu_mem_256=112  
sdtv_aspect=1  
dtparam=gpio_in_pin=18  
gpu_mem_512=144  
dtparam=gpio_out_pin=17 

CEC-Client scan

echo "scan" | cec-client -s -d 1
opening a connection to the CEC adapter...
requesting CEC bus information ...
CEC bus information
===================
device #0: TV
address:       0.0.0.0
active source: no
vendor:        Unknown
osd string:    TV
CEC version:   unknown
power status:  unknown
language:      ???


device #1: Recorder 1
address:       2.3.0.0
active source: no
vendor:        Pulse Eight
osd string:    CECTester
CEC version:   1.4
power status:  on
language:      eng


device #2: Recorder 2
address:       2.4.0.0
active source: yes
vendor:        Unknown
osd string:    raspberry
CEC version:   1.3a
power status:  on
language:      eng


device #3: Tuner 1
address:       2.7.0.0
active source: no
vendor:        Unknown
osd string:    Tuner 1
CEC version:   unknown
power status:  unknown
language:      ???


device #4: Playback 1
address:       2.1.0.0
active source: no
vendor:        Google
osd string:    Chromecast
CEC version:   1.4
power status:  on
language:      ???


device #5: Audio
address:       2.0.0.0
active source: no
vendor:        Sony
osd string:    AV AMP
CEC version:   1.4
power status:  on
language:      ???


device #6: Tuner 2
address:       2.0.0.0
active source: no
vendor:        Sony
osd string:    AV AMP
CEC version:   1.4
power status:  on
language:      ???


currently active source: Recorder 1 (1)

Version:

grep Kodi .kodi/temp/kodi.log | head -3
11:00:41.884 T:1958928384  NOTICE: Starting Kodi (17.4). Platform: Linux ARM (Thumb) 32-bit
11:00:41.884 T:1958928384  NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
11:00:41.884 T:1958928384  NOTICE: Kodi compiled Aug 27 2017 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.39 (200743)

such as?

Reboot and configure the TV, add the entry “hdmi_ignore_cec_init=1” to config.txt, remove it, reset all configurations from kodi CEC add on…

This is what the TV “sees”, BTW

Turn off the PI and unplug the television from the wall for 2 min before booting tv completely and then restarting the Pi?

If CEC were truly broken, there would be an outcry of users overrunning this forum.

2 Likes

I don’t know what to say… That’s the only thing I did, in that order, et voilá!

echo "scan" | cec-client -s -d 1
opening a connection to the CEC adapter...
requesting CEC bus information ...
CEC bus information
===================
device #0: TV
address:       0.0.0.0
active source: no
vendor:        Samsung
osd string:    TV
CEC version:   unknown
power status:  standby
language:      eng


device #1: Recorder 1
address:       1.3.0.0
active source: no
vendor:        Pulse Eight
osd string:    CECTester
CEC version:   1.4
power status:  on
language:      eng


device #3: Tuner 1
address:       1.0.0.0
active source: no
vendor:        Sony
osd string:    AV AMP
CEC version:   1.4
power status:  standby
language:      ???


device #4: Playback 1
address:       1.1.0.0
active source: no
vendor:        Google
osd string:    Chromecast
CEC version:   1.4
power status:  on
language:      ???


device #5: Audio
address:       1.0.0.0
active source: no
vendor:        Sony
osd string:    AV AMP
CEC version:   1.4
power status:  standby
language:      ???


currently active source: unknown (-1)

Are you saying this resolved the issue?

Additionally, Chromecast devices are known in some instances to create issues with other connected CEC devices. If the issue is not resolved, try removing the Chromecast.