HDMI-CEC remote commands sent to wrong output/channel on LG TV

I think this is down to my TV, but before I throw in the towel, I thought you guys might be able to help…

I have an LG323000 TV (its pretty old ~2009), running the latest firmware that is available from it.

I have a Pi B+ running Kodi/OSMC attached to it on one of the HDMI ports. The other HDMI ports usually have a sky HD box and and xbox 360 attached, but they have been disconnected for diagnostics.

I want to be able to use the TV remote to control OSMC via HDMI-CEC (Simplink in LG terms). When I press buttons on the remote, nothing happens in OSMC. I have debugging running.

However, if I switch the TV channel to one of the other HDMI inputs (the one that normally has the sky box attached), and then press buttons on the TV remote, I can see in the debug log that OSMC is receiving them.

so my TV is sending the commands through to the Pi, but only when the channel displayed on the TV is NOT the pi.

I’ve tried plugging the PI into the same HDMI port at that its sending the commands down, but when I do this, it just switches to sending the commands down the other, now disconnected, port.

As I said, pretty sure this is the TV and I probably can’t do much about it,.but thought I’d ask.

Any ideas much appreciated…

go CEC not automatically connecting after upgrading to staging · Issue #495 · xbianonpi/xbian · GitHub contact @hackedbellini

the same setup same troubles, but over the years he got a method(s) how to make cec almost fine
it includes some adaptation of HDMI cable (one specific pin signalling something must be disabled -
this is causing the jumping around).

he will tell you details.

Go to Settings->System->Input Devices->Peripherals->CEC, then near the bottom of the list you should find a setting “HDMI Port”. Change this to the number of the HDMI port that your Pi is connected to.

Thanks guys.

@mk01 Thats quite a thread, thank you. I’ve had a look through it, not sure the issue is quite the same, but worth a try if I can avoid being too ham fisted.

@DBMandrake - I don’t have that option (perhaps because I’m running OSMC RC2?) - The closest are 'Physical Address (overrules HDMI port) and ‘COM port (leave empty unless needed)’ - I’ve played with both of these but with no success.


I sent you to that thread only to get contact to that user, the thread is quite relevant for LGs, but not yours specifically.
(sorry, should have been probably more specific about that)

But that user was solving exactly problem you have and solved it (owning Sky HD Box too, when he had both attached
TV was switching sources (don’t know details) and I remember, he told me had to adapt a cable to mask one
specific pin on the signalling (I don’t keep the details because this looks to be like VERY specific problem/combination),
but he will for sure help gladly.

@mk01 Thanks for the followup & clarification, I’ll contact him.

And you’re right, this is a very specific problem :slight_smile: