HDMI-CEC seems to stop working after a couple of hours

and again:
https://paste.osmc.tv/cujuqetizo

Nothing CEC related in those logs, so hard to tell.
In the first log, I see

cectx c810023c.aocec: tx timeout

at Jan 02 12:57:00

So I assume CEC stopped working after this? Not sure when you went to check.

If still relevant:
I’ve set "When the TV is switched off’ to “Ignore” for the time being.
Nevertheless Kodi does not react on any inputs after switching off & on the TV any more since a few updates. Restarting Kodi is sufficient to get it working again, no reboot required.

Hi Sam,
are there any other setting changes I can try to see if it improves?

Is this immediate?
Can you boot the device with CEC working, turn TV off and on and it’s broken? If so, I think it’s a different issue but might be trivial to fix…

Still thinking.

1 Like

My observation with CEC is, that it comes back to working state after a few minutes of waiting. My vero4k turns off TV and soundsystem after a few minutes of idle to save energy. When I press a button on the vero remote, it turn both ON but sometimes I cannot raise volume and then I play something there’s either no audio because everything is disconnected from each other or I just cannot control the audiolevel with the vero remote. But after stopping and waiting a few seconds and maybe pushing audiolevel buttons, it will work again.

Yes, exactly: It is immediate. I boot the device with CEC working, turn TV off and on - and it’s broken.

Going to try a couple of things.

Still trying,…

Exactly the same behavior here since the last update I believe. Never had an issue with this before. Please, let me know if I can provide any debug information. Thanks.

Since the last update, the “remote-not-working-after-turning-TV-off-and-on-again” bug is gone.
Thanks a lot!

Mine is still causing CEC lockups.

1 Like

Not to me. Everything updated to the latest and still the same issue. @sam_nazarko any clue? Do you need anything to troubleshoot this further? Any workaround or temporary fix?

I have the same problem as my colleague. Years ago I solved it the same way and stayed with version 2022.3 where everything worked great. I recently accidentally updated to the latest one (where it says, among other things, that CEC is fixed), so the detection of CEC and ARC is problematic and the device does not work correctly. Does anyone have the osmc 2022.3 version please??

You can download the older version but ideally we want to fix the issue going foward