HDMI CEC stopped responding on Samsung TV after Aug 5 2019 update

After the latest Aug 5 2019 update on a Raspberry Pi 3B and a HDMI-CEC connected Samsung TV model UE48H6200, the remote suddenly stopped working!

kodi.log -> https://paste.osmc.tv/efoyaropar
cec-client log -> https://paste.osmc.tv/yemakovope

How can we revert to an older version of libcec.so until this is resolved? I tried

sudo apt-get install --reinstall rbp2-libcec-osmc=4.0.4-3

and all other 4.0.0/1/2/3/4 combinations and I always get

I tried with (present and) alternate version 4.0.2-5:

apt-get install --reinstall rbp2-libcec-osmc=4.0.2-5 (or directly, http://ftp.fau.de/osmc/osmc/apt/pool/main/r/rbp2-libcec-osmc/rbp2-libcec-osmc_4.0.2-5_armhf.deb )

to no effect…

Any ideas?

Have you tried power cycling your TV and/or turning the CEC on the TV off and then on again?

If downgrading CEC isn’t fixing things, then libCEC is unlikely to be the issue.

Supposedly this issue was fixed some time ago. See

Fix: set wrong variable by flubshi · Pull Request #352 · Pulse-Eight/libcec · GitHub.

Sam

Hello,

I tried downgrading but the commands - as stated above - do not produce the required result, i.e. downgrading does not take place as the lower version manually entered is not found.

As for the power cycling, yes… I removed the TV power plug for at least half an hour and tried again…

For what it’s worth, if you’re using cec-client (libcec), since the Samsung update, I had to send raw bytes without waiting for a response.

This is my turn-on.sh script:

#!/bin/sh

echo on 0 | cec-client -s -d 1
echo as | cec-client -s -d 1

# Send raw bytes to turn on tv
echo tx 10:04 | cec-client -s -d 1

# Send raw bytes to make current source active
echo tx 10:82 | cec-client -s -d 1

This is my turn-off.sh script:

#!/bin/sh

echo is | cec-client -s -d 1
echo standby 0 | cec-client -s -d 1

# Send raw bytes to make source inactive
echo tx 10:9d | cec-client -s -d 1

# Send raw bytes to turn off TV
echo tx 10:36 | cec-client -s -d 1