HDMI color range

Is it possible to adjust the color range on the Vero 4K as mentioned here: Change HDMI RGB range on Vero

There is no /boot/uEnv.txt


That post is regarding Vero 1, rather than the new Vero 4K.

You can indeed adjust the output colour range, but it would be good to know more about your problem so we can advise accordingly.

Does echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb solve your problem? If so, you can add this to /etc/rc.local for it to be persistent every boot.


My projector is set up to expect the full RGB range because different inputs are being sent to it, including PC content. I had previously set OSMC on the Pi this way as well because of that and because I noticed that viewing pictures with limited color range was discarding information.

It probably makes no difference for videos but I’d like to have the Vero output full RGB for these reasons.

And thanks for the quick reply, as a regular (reading) visitor to the forums I’ve been able to resolve many small issues without even having to open up a topic.


In which case running the above command should have things working as expected for you. If this is the case, add it to /etc/rc.local.



1 Like

It appears that command switches to RGB output but not “Full RGB”. If I let my projector keep the full range all dark tones are washed out.

It can vary depending on the supported gamut. You can set your display to 32-bpp.

Personally I would leave it as is if everything looks OK.

Running with the command will cause the input signal not to be recognized when restarting the Kodi service. I have to manually force a refresh, so entering the line via ssh will bring the picture back.

I guess that means staying with YCbCr 4:4:4 for now.

Can you explain what you mean?

Setting output_rgb should be fine, but you might need to restart Kodi.

It probably doesn’t matter about chromacity for the GUI. Kodi will automatically change it for playback if necessary.



There is a fifty percent chance that restarting Kodi will cause the display to stay blank. So either I reboot the whole device or run the above command as a workaround.

I thought the signal loss was because of me forcing the RGB output but after having restarted Kodi (not the Vero) a few more times it doesn’t seem related.

There have been some improvements that aren’t released yet. Let me know if you’re still having issues after the March update