HDMI connection issues?

hello guys,

I use the Vero 4k+ with my LG Oled c7 and a denon avr 2400h avr.

My TV is connected from the HDMI 2 (ARC) to the AVR HDMI OUT - Monitor ARC.
On the TV Menu i enabled audio passthrough over HDMI, set to automatic and simplik CEC enabled.

When playing something from the LG’s internat Netflix App, the sound is amazing, really immersive, despite bein lossy Atmos.

My Vero on the other hand is connected from the own HDMI Port to the AVR Media Player HDMI Port.

When playing an Atmos file, the AVR shows ATMOS, but the sound is poor, not immersive at all, it’s like the surround back channels were almost muted and everything came from FR, FL and center speakers.

i folowed the guide on the wiki and enabled audio passthrough for everything, it’s set to 7.1

can somebody advise me on what i could try here?

thank you

Mario Pedro

Please go to My OSMC -> Logs and enable a set of logs so we can check your audio is configured correctly.

If you also enable debug logging so we can see passthrough is working as expected.

Can you also test with another Atmos device if you have one and see if you also experience issues? The internal player may use different settings or post-processing.



Hello Sam,

thanks for the fast reply. I think i managed to get the sound right, but unfortunately now another issue arrised…

Now when i try to play Atmos content, either it doesn’t open the files, or my TV complains that there’s no signal and i should enable ARC (It is already enabled). All other content work perfectly.

I think it’s one big mess of HDMI settings and connection around Here :disappointed_relieved:

The only other DA device i have is the TV and that works great

I will upload some Logs my friend, just got to check how to do that.

Get right back to you

Here is the log:



Mario Pedro

Can you please upload all logs?

What’s the make and model of your AVR and TV?


Of course Sam


I have a LG C7 Oled TV and a Denon x2400h AV receiver.

Btw, now i get always the message:

“about to go to sleep. Press cancel to abort”.

Something like this :confused:

Sorry about this mess :sweat:

Mario Pedro


Your log is empty, please try again.

How to submit a useful support request - General - OSMC

Thanks Tom.

Make sure that you have the AVR set to not do extra processing on the sound. On my Yamaha I need to press the ‘Straight’ button. I assume that the Denon has a similar setting.

I will look Into it bmillham :slight_smile:

So here the log again:

Enabled debug logging
Reproduced the issue
Selected all kodi logs


Got a strange message on the top right screen:

“Will go to sleep after playing Video” aomething like this. Jeez :frowning:

Thanks for all the effort

Mario Pedro


Should be fixed in the next update in a couple of days.
I wasn’t brave enough to release it on Christmas day as things could go wrong.

So it’s a known issue Sam?

The “going to sleep. About to…” thing or the HDMI issue?

Thanks for looking into it

Mario Pedro

It may be. We have some fixes for loss of signal in the next update. My advice is to wait a couple of days and let us know if things haven’t improved.



OK, so let’s wait :wink:

It’s just strange that it has been working until today.

Changed the GUI resolution from HD to FullHD, that’s when it started :confused:

Thx to everyone involved.

You can close the thread now of you’d like


Mario Pedro

GUI resolution should be set to 1080. TV will be switched to 4K when you play a 4K video.

The sleep message is probably coming from an addon. I’d guess the Ztools addon. You also have a banned repository; I’d suggest cleaning that up as some of those addons cause problems.

I didn’t realise you’d done that.
Keep the GUI at 1080p.


Hey guys:

Yeah i was aware that the recommended was to have it at 1080p, that’s why i changed it to that.

But that’s when problems started :confused:

Only 4K movies are not playing

Is there a way to clear the cache?

I remember a few years there was an Addon for that? Maybe that will fix it


Mario Pedro

There isn’t really a cache to clear.


THX for clearing that up Sam

That’s the probability of the TVs Gamma settings being the issue?

I remember changing that based on recommended TV settings?


Mario Pedro

No – I don’t think that will be an issue.


I give up.

I’ll wait for the next update to be able to enjoy 4K Movies again :slight_smile:

Take care and thanks for the effort

Mario Pedro