HDMI (DVI) resolution problem with older display


I’ve tried to find related information on the Kodi and OMSC wikis, but wasn’t able to locate anything of help.

I’ve successfully installed current osmc on a raspi B+. As display I’d like to use an older Samsung 215TW display which only supports a maximal resolution of 1680x1050px @ 60hz (that’s 16:10). It also supports lower VESA resolutions.

Because the display only has a DVI-D connector, I’m using an HDMI-DVI-D adapter.

Unfortunately the display cannot show any video signal at all from the raspi.

I had to change OSMC’s display resolution setting in the GUI using a different display and then switch the HDMI cable. It might be that OSMC somehow resets the setting when switching cables, or some information between the display and the raspi isn’t transmitted correctly over the HDMI/DVI-D adapter.

I’m a cli hacker but have no idea about the configuration of a raspi/omsc system.

Is there a possibility to force OSMC video output to 1680x1050, or on of the lower supported resolutions 1152 x 864, 1280 X 960, 1280 X1024.


I am running osmc fine on a 16:10 monitor.
Also with a hdmi to dvi adapter.
Probably the adapter is faulty?

You could theoretically force the resolution in /boot/config.txt

I, too, am running with this kind of setup - and had to force it when I had trouble with the automatic setting (after some chnage of location and connection detail).
the relevant lines in config.txt would be hdmi_force_hotplug=1 hdmi_group=2 hdmi_mode=58 hdmi_drive=2


thanks a lot for the great help, that is exactly what I was missing.

Unfortunately it still doesn’t work, the Raspi is running in the correct mode, but the monitor is telling me it weren’t and suggesting exactly 1680x1050 @ 60.00Hz as optimum mode.

osmc@osmc:~$ tvservice -s
state 0x12000a [HDMI DMT (58) RGB full 16:10], 1680x1050 @ 60.00Hz, progressive

HDMI-cable and HDMI-DVI-D adapter are working fine when using them with my laptop (Mini-Display-Port->HDMI-Adapter etc.).

Raspi is working fine when connecting a different HDMI-display (in the forced resolution), but:
The display is reporting 1680x1050 @ 59.9Hz.

Could it be that the 0.1 difference in the refresh rate is a problem for the display?

You could try mode=35, to get 1280x1024.
I cannot find the info I was using a few days ago relating to the clock rates you need to achieve each particular ‘rate’, and you may not have defining rates for the display, anyway.
I would recommend, for any change of mode, powering down all the equipment, including display, and then boot it all up again.
NB I also had a blank display, when a tvservice report over SSH login reported all OK, which turned out to be poor contact on one or more of the display connections (quite difficult to diagnose, except by replugging and swapping cables).
Good luck