HDMI flickering when playing videos and running hyperion NG

Hi, I’m running OSMC on a raspberry pi 3b+. I have installed hyperion NG.
The problem is that when I have the hyperion service running, and then I try to play a video from a USB attatched to the raspberry, the video starts and after a few seconds the hdmi signal starts to flicker. If I stop the video, the signal comes back in kodi and stays stable.
If I stop the hyperion service from the terminal and I play the video again, it works properly, without flickering and it stays stable.
I tested to disconnect the leds with hyperion running so they are not consuming current, but the same result.
I have a 10 A 5.1V power supply and if the leds where all of them in white, they should consume 6 Amps.
I have also tested with the multimeter when the signal is flickering, and the voltage stays stable in 5.1.
I have also tried in the config of the pi increasesing the value of config_hdmi_boost up to 11 progresively, but with the same results. So I think it is not a power supply problem.
Hyperion NG works fine, but I do not get it work at the same time when I try to play a video.
I have the pi connected via WiFi, and about peripherals, I have the USB where I have the videos, another USB that is a mini keyboard and a USB grabber which hyperion gets the signal.
I have also installed triggercmdagent to control the pi with alexa and it works fine.
I would really appreciate some help.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hi, Thank you for your quick response.

Here is the link


I hope this helps.