Why is this required again? I thought that hdmi_force_hotplug=1 did not have to be added anymore as of around early last year.

I think popcornmix mentioned this quite some time ago.

I captured the EDID of the TV with the Pi plugged directly into the TVs HDMI port. I did this via the new settings and it has added it correctly to the config.tx but I noticed that it also adds hdmi_force_hotplug=1
which I though was no longer required.

I have audio passthrough set with AC3 capable receiver.

The audio amplicication does not work unless I turn off passthrough. Under Raspbmc I could leave passthrough on and amplification would work for non 5.1DD files. Under OSMC I seem to have to turn passthrough off for files for which I want volume amplification…

Confused a little.

EDIT: I figured out the passthrough volume amplification issue. Disable the passthrough, change volume amplification level to desired level and then re enable passthrough. Volume amplification level is then set for non 5.1DD files.

If you are specifying an edid file to cope with the situation of the Pi being booted before the TV, then hdmi_force_hotplug=1 has always been required.

This is because this setting tells the Pi firmware to act as if an HDMI device is connected even if it isn’t. (or is turned off) If you don’t, the edid won’t work because it won’t think anything is connected.

Thank you - understood. That is exactly how I intended it to work and is now working well.