HDMI - No signal

I have been using a Rpi4 with Kodi/LibreELEC for several years. Due to some issues with unstable network connectivity, I decided to try OSMC instead. I formatted and installed OSMC onto the SD card and booted it on our Samsung TV as normal.

Configuration and setup was great, I mounted my NAS drives for media without issues and the system looked like it was going to be great. I left for a work trip and didn’t get a chance to try the system out properly.

Now when i attempt to use the system, the TV doesn’t appear to be able to detect it. When i power it on or plug in the HDMI cable, the TV reacts: it appears to see something on the cable, it blanks for a second, then returns to “no signal”. I’ve also tried the unit on a HDMI equipped computer monitor, and get the same result, the display flickers a few times and reverts to ‘no signal’.

Now, it is certainly possible that my RPi or HDMI cable somehow spontaneously failed during the weeks I didn’t use the unit, but that does seem unlikely. I did all the setup on the new OSMC installation on the first boot, and the second boot was when it stopped displaying. I suspect that there’s something wrong with the configuration, but don’t know nearly enough to diagnose this myself.

Luckily, I do know that the unit is working. I can ssh into it and retrieve the logs:

Where should I go about trying to solve this issue? Can i force it into some kind of HDMI compatibility mode, or even set resolution/CEC settings manually if it’s having trouble getting the device settings?


There seems to be an issue with your screensaver setting…

<setting id="screensaver.mode">&#x1B;</setting>

Which I assume is probably data corruption due to a bad PSU…

[ 20.190420] hwmon hwmon1: Undervoltage detected!

I’m far from an expert, or even a competent amateur here - but would the screensaver mode settings prevent HDMI communication even pre-splash screen? I don’t get any data at all on boot.

Also, the power supply issue seems to be transient - it does not appear in previous logs I pulled while trying to diagnose this issue.

My experience has been that a RPi starts having issues at a higher voltage than what typically triggers an undervolt message. The fact that the message ever shows up means that either the PSU or the cable between it and the RPi is underspeced or faulty. At that point everything else, in my opinion, becomes irrelevant as that must be rectified first and the data on the SD can no longer be trusted and should be wiped and a reinstall done. Anything else and your just hoping nothing else got borked which can lead to needlessly chasing ghosts in the future.

1 Like

Well, guess I’m going to have to try that. Thanks.