HDMI not working since last update


#1

Hello All, I really hope someone can help me. Since performing the last OSMC update I no longer get an HDMI picture from my Pi.
It is an old style Pi with two USB ports connected to an old (15 yrs+) LG tv. The configuration has worked without issue for over 5 years. If I connect a new (2 yrs old) LG portable to the Pi the HDMI works fine so I can conclude that this is not a hardware fault.
The old LG recognises the Pi is connected but switches to standby.
What was changed in the last update that can have caused this?
I have tried boosting the HDMI output, forcing modes etc. but this has had no effect. Any ideas?


#2

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


#3

Thank you Tom. I will grab a log and upload it. I was hoping this may be avoided because I was using an out-of-the-box setup that was good for 5 years with the only change being the last update…


#4

Thread closed. I feel foolish. Picture’s back on the TV. Don’t know why yet. Probably just old age…