HDMI not working

Hi there,
I have been using my Vero4k+ for months with same HDMI projector and same cable but one day, the HDMI output stops working. I tried to connect Vero to few HDMI monitors but no luck. Projector is working well with any other source. I also tried few HDMI cables. The display/projector usually says nothing helpful but it seems that it’s trying to do something - it’s not dead at all, but picture didn’t show up. There is no picture during boot also.
I have re-install OSMC by new image 2023.01-1. I also tried few older images with no luck.

I am able to connect to Vero via ssh. It looks like everything is working well but HDMI output.
Probably some piece of HW is broken.

If you have any idea what to do, please help.
Logs are here

HDMI looks OK from HW side. An EDID is being read and decoded successfully which is a good sign.

You could try some contact cleaner. From your logs it looks like you tested on a monitor. A log with your device attached to a projector would be useful.

You could also try reinstalling OSMC. If you still have issues, you could try with an older version to rule out an issue affecting you from a recent update.

Hi, so I just connect my BenQ projector. Logs are here
I already reinstalled OSMC many times also with previous versions.
Also I just cleaned the contacts. Still the same.
I am bit of frustrated for all the hours I spent on this. Maybe is time to say good bye and buy another device :slight_smile:
Anyway thank you for your time!