Hdmi safemode

Hello,

i just wanted to replace my old raspberry pi with my new vero2 that arrived this week. when i boot up the vero my screen remains black. my display-setup required the hdmi_safemode option to be enabled in /boot/config.txt on the pi.
i read in the forum that there is a similar way to do this kind of configuration in /boot/uEnv.txt on vero. is there a wiki somewhere or maybe a default file i could look at?

cheers,
bendsch

Can you please describe your TV setup in more detail?

Sam

hi sam,

i use a apple cinema display, together with this adapter: http://www.kanex.com/xd?ref=isp_rel_prd&isp_ref_pos=6

it worked without problems for the pi.

bendsch

Are you able to log in to the device via SSH?

yes!

Hi

The uEnv.txt file exists on Vero 1 devices which use an external SD card to boot. For the Vero 2, those U-Boot parameters can still be configured, but we deliberately obfuscated this to prevent users bricking their devices accidentally and having to undergo some lengthy steps to fix the issue.

I suspect that the EDID read doesn’t work properly with your adapter, which is why you don’t get a proper picture. There are some work arounds for this. I’d like to try this first before we start editing boot parameters.

First, log in via SSH.

Let’s see if Vero 2 has detected an attached monitor. You can do this by running:

cat /sys/class/amhdmitx/amhdmitx0/hpd_state

Please post the result.

If that shows 1, then I’d like to know what modes your display is claiming to support. This can be viewed with:

cat /sys/class/amhdmitx/amhdmitx0/disp_cap

My hunch is the hotplugging doesn’t work properly with the adapter. There are improvements to HPD in the latest kernel which has not been publicly released yet. You can grab it by running the following commands:

Edit /etc/apt/sources.list and change

deb http://apt.osmc.tv jessie main

to

deb http://apt.osmc.tv jessie-devel main
sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot

Sam

hi sam

here are the results:

cat /sys/class/amhdmitx/amhdmitx0/hpd_state
1

cat /sys/class/amhdmitx/amhdmitx0/disp_cap
720p*

i also did the dist-upgrade: but no effect, the screen remains black on reboot.

Bendsch

Okay

So it looks like your display is advertising a preferred mode of 720p and that this is the only possible mode that can be used. It’s possible that the adapter is lying and this is what is causing the problems with the Cinema Display.

What does this show?

cat /sys/class/display/mode

You should be able to get a picture with:

echo 720p | sudo tee /sys/class/display/mode

“cat /sys/class/display/mode” gives the same result
720p

the command “echo 720p | sudo tee /sys/class/display/mode” does not seem to have any effect, at least i get no picture executing it …

Is your display actually capable of showing a 720p picture? What resolution did you use on Pi?

I suspect the problem is the adapter isn’t advertising the real modes that the display supports.

i did a quick test with the raspberry: switched the resolution in osmc interface to 720p and noticed that the display turned black. so i guess that the cinema display is only capable of displaying 1200p.

however when i tried “echo 1200p | sudo tee /sys/class/display/mode” on the vero2 i still got no picture.

The Vero 2 doesn’t have a 1200p mode defined in the kernel, to my knowledge. We could potentially explore adding one.

Can you confirm the actual resolution that the Cinema Display has when you connect it to a Pi?

it has 1200p, if i select that resolution manually on the pi i get a picture. (i think that is also the resolution that is used under “Desktop” option).

What is the full resolution (and refresh rate)?

It might be useful for me to see how Pi handshakes so I can see if it’s picking up the EDID properly.

Sam

full resolution: 1900x1200p
Refreshrate: 59.94

should i upload the full logs to provide that information or is there a better way?

I will have to see if I can generate a modeline for this monitor. In the interim, can you even try forcing 480p (480p) to mode, and see if it works?

I also want to see EDID data from the display:

cat /sys/class/amhdmitx/amhdmitx0/edid

and can you also upload the edid information from the journal? Mine looks like

Jul 24 21:01:34 osmc-Cortland kernel: hdmitx: edid: blk0 raw data
Jul 24 21:01:34 osmc-Cortland kernel: 00ffffffffffff004dd9022b0101010130140103805932780aee91a3544c9926
Jul 24 21:01:34 osmc-Cortland kernel: 0f505420000001010101010101010101010101010101023a801871382d40582c
Jul 24 21:01:34 osmc-Cortland kernel: 4500c48e2100001e000000fe000a202020202020202020202020000000fc0053
Jul 24 21:01:34 osmc-Cortland kernel: 4f4e59204156414d500a2020000000fd0018781a5f11000a20202020202001a4
Jul 24 21:01:34 osmc-Cortland kernel: 
Jul 24 21:01:34 osmc-Cortland kernel: hdmitx: edid: blk1 raw data
Jul 24 21:01:34 osmc-Cortland kernel: 02033ff14d90040503201213140211011f1038097f070d7f070f7f071507553d
Jul 24 21:01:34 osmc-Cortland kernel: 1fc05706006754005f7e01835f00006f030c002400b82820c005014000172000
Jul 24 21:01:34 osmc-Cortland kernel: 0000000000000000000000000000000000000000000000000000000000000000
Jul 24 21:01:34 osmc-Cortland kernel: 0000000000000000000000000000000000000000000000000000000000000013

Sam

sorry i made a mistake: the full resolution of the cinema display is 1920x900p.
Refreshrate: 59.94

i tried that, but it had no effect.

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/edid
Receiver Brand Name: MDP
Receiver Product Name: MDP
EDID block number: 0x1
blk0 chksum: 0xd2
Source Physical Address[a.b.c.d]: 1.0.0.0
native Mode 71, VIC (native 4):
ColorDeepSupport 0, MaxTMDSClock 0
4 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
Audio {format, channel, freq, cce}
{1, 1, 7, 6}
Speaker Allocation: 0
Vendor: c03
Rx 3D Format Support List:
{VIC FramePacking TopBottom SidebySide}
{ 4 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }
{ 0 0 0 0 }

this i dont know how to do.

bendsch

Just do sudo journalctl | paste-log and upload the URL

From above it looks like your adapter is only showing vicmode4 which isn’t good. I would try connecting to a 720p TV or something, then swapping the HDMI over (HPD should not be triggered in latest kernel). It would be interesting to see if that gets you a picture.

http://paste.osmc.io/wuqaxoboqu

at the moment its not possible for me to try this monitor swapping thing …

is there a possibility we could just copy the settings from the pi?

Bendsch

It would be ideal for you to try another monitor and see if this helps.

Jul 24 22:56:13 osmc kernel: hdmitx: edid: find IEEEOUT
Jul 24 22:56:13 osmc kernel: hdmitx: video: get current mode: 720p50hz
Jul 24 22:56:13 osmc kernel: hdmitx: system: [set_disp_mode_auto] ALREADY init VIC = 19
Jul 24 22:56:13 osmc kernel: hdmitx: audio: audio channel num is 0
Jul 24 22:56:13 osmc kernel: hdmitx: audio: SPDIF
Jul 24 22:56:13 osmc kernel: hdmitx: audio: current VIC: 19
Jul 24 22:56:13 osmc kernel: hdmitx: audio: audio sample rate: 0
Jul 24 22:56:13 osmc kernel: hdmitx: audio: reset audio N para
Jul 24 22:56:13 osmc kernel: hdmitx: audio: PCM out to HDMI

Shows that the adapter is advertising a 720p mode as the preferred mode. This may be why you have problems, particularly if the Cinema Display doesn’t accept this resolution.

  • Show your full config.txt on Pi

Boot Pi without HDMI, and run:

vcgencmd set_logging level=2097152

Insert HDMI cable
Post output of:

vcdbg log msg | paste-log

Hopefully this gives us more info about the monitor and how to drive it.