HDMI signal drops on a 4k/50 content with forced 4:2:2 css

I’ve recently upgraded my TV to finally have 4k and enjoy Vero to the fullest. The signal path is Vero 4k+ to HDMI: Media Player on Denon 2400 to HDMI 3 on Sony 75X950G.

The cable from Vero is the original Vero cable and cable connecting to TV is Monoprice 2 meter premium certified HDMI.

Everything looks amazing coming from 7 years old edge-lit Samsung but one specific content seems to cause issues: 4k SDR 50 Hz with PCM multi-channel audio. There are “HDMI signal dropouts” where the TV loses the signal (goes black for a moment, sometimes with signal lost error from TV) and sometimes the audio indicator on the AVR screen blinks off at the same time. Usually though the audio is heard while the video is gone.

It should be noted that the Vero would not show any picture at all unless I enabled “Force 4:2:2” setting in Vero after setting the TV “HDMI format” to “Enhanced” (this enables HDR and HDMI 2.0 in general to my knowledge).

Video processing on the AVR is disabled except for overlays.

I suspect that the problem happens with this content because it is the only really high-bandwidth content I have. I don’t have other high-fps content but will try to find some other 50 or 60 fps content.

Does that sound reasonable? With the “Force 422”, 4k and 50 Hz I believe the bandwidth is at the higher end of the 18 Gps maximum signal rate? This content should not need 4:2:2 chroma subsampling which increases the bandwidth need higher than required but there is no picture without forcing 422 for everything.

It is a shame that Vero needs to force 4:2:2 chroma subsampling and while I do understand what it does, I do not understand why it is needed. Especially a shame if I will find out that all higher-fps content is unplayable.

When setting up the system I did play around with the different control files at /sys/class/amhdmitx0 and looked at forum threads here around forced 4:2:2 but eventually gave up and just enabled the forced setting.

What is the reason for requiring “forced 4:2:2” on some TV sets?

I do not have the possibility to debug it until the next week but wanted to ask about opinions of the clever people here.

Obviously I will test with debug log, change cables, try to connect Vero directly to the TV, and so on next week when it doesn’t disturb the peace at home :wink: It already caused a disappointment that the planned watching did not happen so I can’t make the situation worse by starting to debug the system at the living room…

Most commonly:

  • LG TVs (to name the most popular, problematic brand)
  • HDMI cables that cannot carry full signal, usually due to length.
  • Various AVR quirks

If you run Vero direct to TV, are things better?
If not – try the HDMI from AVR to TV on Vero TV. Are things better?

HDMI cables should always be suspect so that is always a good place to start. You can also try moving the input on the AVR to the one physically closest to the output as that can sometimes make a difference.

Sounds like I may have misunderstood the option.

I thought that “Force 4:2:2” would send 4:2:0 content as 4:2:2 increasing the bandwidth, no change in picture quality - but it also changes 4:4:4 content to 4:2:2 decreasing the bandwidth, I suppose slightly degrading picture quality for content that is originally 4:4:4?

4:4:4 content is at least PC output (?) but I thought film/TV content is 4:2:0? So sending it as 4:2:2 would increase the bandwidth requirements (and thus quality requirements for signal path/cables, etc.) - wouldn’t this mean enabling forced 4:2:2 would only increase problems with cables? Or with this option disabled Vero would send video as 4:4:4?

:confused:

It’s complicated, and it’s not just about bandwidth. HDMI 2.0 cannot carry 4:4:4 at 4k50/60Hz with 10bit video (eg ‘HDR10’) but can just manage 8 bits (18GHz). The default for 4kHDR is therefore 4:2:0 which needs less bandwidth than 4:4:4 8-bits and offers the prospect of ‘straight through’ video as most content is 4:2:0. But some TVs don’t seem to like that. 4:2:2 carries 10 bits in the same space as 4:4:4 8 bits and we’ve found that works on TVs that don’t like 4:2:0.

Bottomline - if you have issues with 4:2:0 you are not alone and we don’t know exactly why it happens. (We hear some other media devices don’t actually bother with that format). If you have issues with 4:2:2 it is probably a bandwidth issue for which cables and cable connections would be the first place to look.

1 Like

This is very helpful, thank you. My suspicion seems feasible then and I’ll start troubleshooting with the hypothesis that signal quality might be affecting high-bandwidth content.

Those Monoprice HDMI cables have been recommended everywhere so I’ll be surprised if that turns out to be the issue.

Is the cable bundled with Vero 4k+ supposed to support 18 Gbps?

The first thing I’ll do when alone is to change the cables and then continue with other basic steps (well documented at this forum on other people’s threads).

Edit: ordered “Certified Ultra High Speed” cables, unfortunately available only 6.5 ft lengths. Will update the thread in a few weeks after they arrive.

I can’t speak for anyone else, but I certainly had fewer problems after I’d switched mine for a cable that was certified as “premium high-speed”.

Yes, but IIRC they are not certified. I would start with a squirt of contact cleaner in the plugs and sockets.

FWIW, I’ve just had one cable play up (after 2 years of daily plugging/uplugging on my workbench). I swapped it end for end and that fixed it :stuck_out_tongue: