HDR Autoswitch causing issues on my LG OLED65C8


#1

Hi,

New user, it’s good to be here!

OK, got a Vero 4K as well as an LG OLED65C8 recently and they work fine together. One thing troubles me though.
First thing I did before even playing anything was to “Enable HDR autoswitching”. Then HDR files (demos found on the net, bluray rips) randomly refused to play (TV says “no input”).
As soon as HDR autoswitch is disabled, everything plays flawlessly, and TV switches back and forth between SDR and HDR, colors/brightness are just fine.

My questions are:

  • What is “HDR autoswitch”?
  • How does it work?
  • How come it seems to hurt in my case?

Thanks


#2

First question is, whitch resolution did you set? You should go with 1080p since it performs better and Kodi Scaling isnt quite the best out there. Second positive thing is that your TV does the upscaling on 1080p content.

Normally, HDR autoswitch switches between two colorspaces to give you accurate colors in both HDR and SDR. (BT.2020 and BT.709 (Rec.709)). Your TV should show the ‘HDR enabled’ banner on the right left corner.
I do have an LG 55C7 and HDR switching does work just fine, but only if resolution in settings is set to 1080p (which is better anyways cause you want the TV to upscale lower res content).

I don´t know how autoswitch does work exactly, but my guess is that the player is able to read metadata in which the correct colorspace is documented.

Are you running on latest firmware?

Cheers :wink:


#3

Also try another HDMI cable if you can.

Sam


#4

That’s correct. We detect colour primaries and switch accordingly. This was added in April as an experiment and will be refined very shortly to work a little better than it currently does :slight_smile:

Sam


#5

Yep, HDMI cable was a problem for me too. Vero 4K sometimes disappeared and TV showed no signal. Got a solid HDMI-cable from amazon and its works fine now.


#6

Sometimes the issue is not the HDMI from Vero to receiver, but the receiver to projector / TV etc.


#7

Yep, check both cables just in case :wink:


#8

Thanks for you feedback, both of you.

With OSMC resolution set to 1080p or 2060p --> same issue.
I have decent HDMI cables. Nevertheless, I tried another (decent) one, same issue.
The Vero 4K is plugged into the TV directly, no receiver.

With HDR autoswitching ENABLED and trying to play an HDR stream, randomly (AFAICT), the TV switches to HDR (HDR logo in the upper right corner, I guess the TV receives the HDR metadata), then a couple of seconds later I get “No signal”. It seems OSMC is somehow “playing” the stream since I can see the external HDD led flashing. FYI, no problem at all with SDR streams.

The funny thing is that, all plays well exactly as expected (BT.2020 vs BT.709 as reported by the TV) automatically with HDR autoswitching DISABLED.


#9

Yes – that sounds similar to reports about HDR switching. It’s still experimental. You can manually set 10-bit output if necessary.

Sam


#10

You mean “echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr”?
I thought that was default by now but I just checked and indeed my /sys/class/amhdmitx/amhdmitx0/attr is set to “reset”.

I don’t need to change anything since it all works fine for me but if you need me to check anything or even test anything related to HDR autoswitching enhancements, just let me know.


#11

Have you enabled the HDMI Ultra HD Deep Colour setting on the HDMI input you are using?


#12

yep


#13

Just a quick feedback after the “2018.06-1” update. HDR autoswitching is still not working for me. It behaves a little differently though. This time, the HDR stream plays fine for a few seconds then somehow stops and the TV complains there is no signal.

I’m now back with HDR autoswitching disabled and 10 bit output forced since it clearly improves banding / posterization.


#14

That’s expected then – as HDR autoswitching hasn’t significantly changed yet (just some minor improvements)

Sam


#15

I’ve just got my Vero 4k+ and attached to my LG OLED C8, and i’m having trouble with
the “no signal” after starting HDR content. It should be fully updated.

The screen comes back after I stop the content. If I stop and start a few times, sometimes it works.

It seems related to the display resolution, It was running in 720p initially and the HDR content worked fine, switching to 4k resolution caused the problem, (potentially also changing the delay after switch setting made it worse still)


#16

Hi,

Do you mean you’ve set the gui resolution to 4k? If so I would set that to 1080p and let your tv upscale the gui and then hdr switching should work as expected, I believe.

Thank


#17

If you are running the August release, then @Tom_Doyle’s advice is good. Expect an update shortly which should allow you to set a 4k GUI resolution, but there’s really not point in using that.


#18

No i have my UI set to 1080p, that doesn’t help.

Its when i power on the vero without the tv on or something that makes it go into that funny state where you cant change resolution/framerate in settings/system/display…

It was stuck to 720p then, but hdr content played fine without the no signal problem, but stuck in 720p. After a reboot framerate/res switching works again but then the hdr content triggers the “no signal”, unless i stop and start and stop and start a few times.


#19

The October release was just published, so I’d suggest that you update again. Make sure that if you are on staging that you remove that from your sources.list.


#20

We’ve fixed this in the October release.

Sam