HDR Autoswitch causing issues on my LG OLED65C8

We will need to see some debug logs of working vs not working then.

We’ll get this solved

Cheers

Sam

Okay, here some logs:

First log: https://paste.osmc.tv/awaciwewuq
I activated debug logging, restarted KODI and played the “The World in HDR”. Result: Demo played, but with banding.

Second log: https://paste.osmc.tv/iyirusocox
I activated HDR auto switchting (I’m on the Aug update again), restarted KODI and played the same file. Result: Black screen.

Third log: https://paste.osmc.tv/okeyeduyim
I deactived HDMI UHD Color and kept HDR auto switching on, restarted KODI and, again, played the same file. Result: Black screen.

Hope this helps. Please tell me if you need anything else.

I confirm this issue with that file, same settings and LG65C8. I use only HDMI premium cables so it’s something within OSMC/Vero 4K+.
No issue with other kind of MKV 4K HDR 10bit

We will look in to this

1 Like

Similar issue, I get black screen with audio when playing any content local, NFS, or streaming when I have Enhanced HDMI function on my Hisense 55H8C. GUI is set to 1080P, Auto Refresh Rate enabled. My setup is Vero 4K to Denon AVR-S910W to Hisense 55H8C. Has been working flawlessly before October update. I can upload logs if needed, just thought I would chime in with a possible related issue.
https://paste.osmc.tv/otovivedil

This is me enabling the the enhanced HDMI mode at the GUI and then turning it off due to no signal. Then playing a movie, and trying again to enable Enhanced HDMI, and turning it back off during playback, due to no signal.

Thank you. Logs would be good. For you and anyone else reporting, we need to know:

  • OSMC version (we can get it from the logs)
  • HDMI chain: AVR/soundbar make/model, TV make/model
  • HDMI input setting (variously named but it seems to correspond to HDMI1.4 or HDMI2.0+ compatability)
  • resolution, framerate and bitdepth of video being played (we can get that from logs)
  • response of display (ie ‘correct’ resolution etc/‘incorrect’ resolution/blank screen) with GUI and video

I just downgraded to August update and enabled HDR autoswitching and everything works just as it did before.

I will test this tonight, i recentrly installed my Vero4k but didn’t active the “Autoswitch HDR” button yet. That’s probably why everything - HD/4K SDR/HDR material - is played in 4:4:4 (8bit i think?), according to my AVR.

TV: LG OLED55C7
AVR: NAD T758 v3

I’ll let you guys know how my setup behaves.

The auto-switch HDR option is deprecated in the latest version of OSMC.

What does this mean exactly? Should i leave it turned off?

There is no manual setting anymore.

I see. So for now i just have to stick with everything being played out with 4:4:4? I thought there would be auto-switching between the content’s color space / chroma.

If you are still experiencing issues with this, you should be providing diagnostic info as requested by @grahamh above so that we can get this sorted for all affected users.

HDR Autoswitch causing issues on my LG OLED65C8 - #71 by grahamh

There is autoswitching in the October update enabled by default. We are working on the quirks of some TVs and will have some updates shortly.

The main problem is with 4k50/60Hz material. If you turn off ‘Ultra HD deep colour’ you should at least be able to play 4k50/60Hz 10-bit videos at 1080p.

Thanks for the feedback, I appreciate it. Looking forward to something new to try :).

Sam et al.

I’m experiencing similar symptoms with my setup since the October update. When I play video files, my television displays a “no signal” warning. I’ve managed to get around this by stopping the video file, manually turning off/on the television, then (re)setting the resolution in system settings to 1920x1080p 60fps. Afterwards I can play the video file without issues, but the problem seems to return after I’ve put my televison and receiver on standby for a few hours.

The following log file includes the events of attempting to play a video file, the television having a “no signal” warning, me turning off/on the television, and then stopping the logging via the GUI. I didn’t reboot OSMC after enabling logging since that made the issue unrepeatable before.

http://paste.osmc.tv/viyicubivo

Setup:
Samsung UE32EH5000
Marantz NR1506 AV Receiver
Vero 4K

Thanks

For a workaround for now, please see Video improvement details - #7 by obstler42

1 Like

Has anyone else tried setting the GUI to 1080p50 (rather than 1080p60) and playing 4K files? Big improvement for me when I did this.

All files that i throw at it play out. But… all content is (according to my AVR) played in 4:4:4 30bit(??)*
YCbCr.

*i found this information: Color depths of 30, 36, and 48 bits per pixel are in use, also referred to as 10, 12, or 16 bits per RGB channel/sample/component. So 30bit = 10bit.

To my eyes, HDR content looks like it’s intended, but 1080p24 SDR content looks oversaturated. That would make sense, since it’s played out at 4:4:4 YCbCr where it should be 4:2:0 i guess.

I will try to upload some logs this weekend.

That is expected on the October release. There were some issues trying to switch bitdepth on the fly so we are setting 10(30)bits if your TV has deep colour, otherwise 8 bits. 8-bit content played at ‘10-bits’ should look exactly the same as if it was played at 8-bits.

Over-saturation is another issue we are dealing with separately.

1 Like