HDR Autoswitch causing issues on my LG OLED65C8

I see. So for now i just have to stick with everything being played out with 4:4:4? I thought there would be auto-switching between the content’s color space / chroma.

If you are still experiencing issues with this, you should be providing diagnostic info as requested by @grahamh above so that we can get this sorted for all affected users.

HDR Autoswitch causing issues on my LG OLED65C8 - #71 by grahamh

There is autoswitching in the October update enabled by default. We are working on the quirks of some TVs and will have some updates shortly.

The main problem is with 4k50/60Hz material. If you turn off ‘Ultra HD deep colour’ you should at least be able to play 4k50/60Hz 10-bit videos at 1080p.

Thanks for the feedback, I appreciate it. Looking forward to something new to try :).

Sam et al.

I’m experiencing similar symptoms with my setup since the October update. When I play video files, my television displays a “no signal” warning. I’ve managed to get around this by stopping the video file, manually turning off/on the television, then (re)setting the resolution in system settings to 1920x1080p 60fps. Afterwards I can play the video file without issues, but the problem seems to return after I’ve put my televison and receiver on standby for a few hours.

The following log file includes the events of attempting to play a video file, the television having a “no signal” warning, me turning off/on the television, and then stopping the logging via the GUI. I didn’t reboot OSMC after enabling logging since that made the issue unrepeatable before.

http://paste.osmc.tv/viyicubivo

Setup:
Samsung UE32EH5000
Marantz NR1506 AV Receiver
Vero 4K

Thanks

For a workaround for now, please see Video improvement details - #7 by obstler42

1 Like

Has anyone else tried setting the GUI to 1080p50 (rather than 1080p60) and playing 4K files? Big improvement for me when I did this.

All files that i throw at it play out. But… all content is (according to my AVR) played in 4:4:4 30bit(??)*
YCbCr.

*i found this information: Color depths of 30, 36, and 48 bits per pixel are in use, also referred to as 10, 12, or 16 bits per RGB channel/sample/component. So 30bit = 10bit.

To my eyes, HDR content looks like it’s intended, but 1080p24 SDR content looks oversaturated. That would make sense, since it’s played out at 4:4:4 YCbCr where it should be 4:2:0 i guess.

I will try to upload some logs this weekend.

That is expected on the October release. There were some issues trying to switch bitdepth on the fly so we are setting 10(30)bits if your TV has deep colour, otherwise 8 bits. 8-bit content played at ‘10-bits’ should look exactly the same as if it was played at 8-bits.

Over-saturation is another issue we are dealing with separately.

1 Like

We have now made some tweaks to the kernel which should:

  • stop vero trying to set combinations of resolution, bit-depth and colourspace that your display cannot use
  • allow you to force 422 colourspace to see if you get a better result (LGs may well work better but Philips will be worse, it seems). Use echo 422now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr.
  • play 10-bit SDR as BT709, not BT2020.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

3 Likes

Ok now that demo MKV file runs smoothly, with 4K@60hz 422 BT2020 12b HDR 593MHz according to my hdfury Vertex. Seems good, no banding or other artifacts. In addiction, for the first time I’m able to run Leia 18 347 release without that annoying reboot loop that made it unusable until now. The only SDR 4K file I own runs as 4K@23.973 444 BT709 10bit 371MHz according with my Vertex, as always ran before. Let me know if you need anything else.

I applied the update, but I don’t see any improvment. With UHD color mode enabled, the demo file still does not play. With UHD color mode disabled, the demo file plays, but with very visible banding.

Log 1 (UHD color mode enabled, black screen): https://paste.osmc.tv/igolebuyef
Log 2 (UHD color mode disabled, banding): https://paste.osmc.tv/izexoforec

/edit: I’m using the HDMI cable I got with the Vero4k. It’s directly connected to my TV (Samsung KS8090).

Consider to change that cable with a premium certified one. Everything runs well now with new kernel on my LG65C8.

Yes, that’s worth a try. Another thing you (@stinger5) could try is:

echo 422now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

while playing that demo vid.

I tried…

echo 422now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

… but the screen remained black. I will buy a new HDMI cable just to make sure we are not hunting a ghost here.

I’ll report back once I have it.

That’s a surprise. It should be 420,10bit unless you have set any values manually. Can you post a log for that, and cat /sys/class/amhdmitx/amhdmitx0/config while the vid is playing, please?

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 97
VIC: 97 3840x2160p60hz
Colour depth: 10-bit
Colourspace: YUV422
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

Log: https://paste.osmc.tv/agiqiveyeh

Useful, thanks. You are getting 422,10-bits because you are running Leia and there is no option in Leia to whitelist a 4:2:0 mode.

But Hdfury Vertex report that, it could be right…

Can you remind me how that 4k60Hz clip plays with Leia if you downgrade your HDMI input (non-Ultra HD on LG?). It should come out as 420,8-bit as it does on Krypton.