HDR Autoswitch causing issues on my LG OLED65C8

My 2 cents on this.
I have been forcing ‘444,10bit’ into /sys/class/amhdmitx/amhdmitx0/attr (set in /etc/rc.local) since May 2018 and all my HDR files (demos and movies) have been working fine on my 65C8.

Now I just installed the october update.

I can’t find the “Enable HDR autoswitching” any more.
Forcing ‘444,10bit’ seems to still be working (at least echoing /sys/class/amhdmitx/amhdmitx0/attr provides me wit the expected output).
I tested plenty HDR files. All are still working.

Good grief! so some C8s are OK but some are not?

It has been removed.

Are you saying this doen’t work without forcing 444,10bit? What is happening if you don’t force it?

I haven’t tried yet without forcing 444,10it.

I am having the similar problem.

When I removed the 444 10 bit line from rc local my movies do get the lg b7 to switch to hdr mode but they are played back in 8 bit mode rather than 10 bit.

This happens to me aswell since the October update. If I enable UHD color mode, I can’t get any 4k files to work (neither 24p nor 60p). TV goes black until I press the stop button. I also can’t set Kodi to 4k (which I don’t usually do, just as a test). It works if I disable UHD color mode.

/edit: TV: Samsung 65KS8090

Please tell me if you need any logs (and how I can best produce them) to track down the issue.

Not sure if this helps

Which screen is this? By that, 444,10bit should not work at 50/60Hz (@swagner74 says it does) and 420,10bit should work (@darkskiez says it doesn’t).

That’s in the e-Guide for the 65" C8
LG e-Guide

There is also a PDF manual with the same info buried towards the endLG_Capture2

That is all based on the HDMI Ultra HD Colour settings in the picture menu.
I’ve just installed 4 of the C8 screens in a client’s house and they all have intermittent handshake issues with all sources as well as (what feels like) weekly firmware updates.


Forcing 444,10bit or 422,10bit doesn’t work either, even though my TV supports it as per manual:

Seems like 4k only works with UHD color mode disabled (=> 8 bit) since the October update.

Per @CaptainMoody, 444,10bit will not be supported at 50/60Hz. Only 420. This is entirely HDMI2.0 compliant. Please don’t try setting the colourspace (444,422) with attr. Just use 10bit, 8bit etc if testing.

Couldn’t find any reference in the manuals but just found this info on RTings:

Most TVs today allow you to enable chroma 4:4:4. Different brands place these settings in different areas of their menus.
First, go to the TV’s picture settings and select and enable “HDMI ULTRA HD deep color”. Then, press the input button, then select “All inputs”. Pick the input you would like to enable the feature on then edit the icon. Select the PC icon.

If I only force 10bit (no colorspace) the screen remains black for all my samples. If I force 420,10bit, UHD playback somewhat works (with UHD color mode enabled). 24p looks ok, a 60p demo doesn’t work however.

Keep in mind the same Demo worked before the October update. No firmware update for my TV in the mean time.

Seems I need to downgrade…

Okay, downgraded to prev. update. All my samples work again, but with the wrong chroma subsampling (=> banding).

See this Demo:

With the Aug update, this Demo produces heavy banding (4-5 seconds in, the sky behind the skateboard). No banding whatsoever when I play the Demo with the internal media player, so my TV is certainly able. If I enable HDR auto switchting, the Demo only produces a black screen.

With the Oct update, the Demo only produces a black screen if UHD color mode is enabled. It works with UHD color mode disabled, but produces heavy banding.

So this is my guess: The Oct update actually improved things quite a bit, but it seems it somehow produces a video stream that my Samsung KS8090 can’t handle if UHD color mode is active.

Did you apply any hotfixes or hardcode anything in /etc/rc.local?
If so: you’ll want to remove that.

I’ve done some more testing, going through a set of five 4K HDR test clips I made 26 attempts to play the files and 4 of them succeeded (not always the same file). So it is randomly working.

Turning off the UHD Deep Colour on the LG allowed the file to play, however the TV forces it back on when it detects HDR. The video kept playing put bizarrely it was now in 1080p.

No hotfixes applied.

No hotfixes, nothing in rc.local.

We will need to see some debug logs of working vs not working then.

We’ll get this solved



Okay, here some logs:

First log: https://paste.osmc.tv/awaciwewuq
I activated debug logging, restarted KODI and played the “The World in HDR”. Result: Demo played, but with banding.

Second log: https://paste.osmc.tv/iyirusocox
I activated HDR auto switchting (I’m on the Aug update again), restarted KODI and played the same file. Result: Black screen.

Third log: https://paste.osmc.tv/okeyeduyim
I deactived HDMI UHD Color and kept HDR auto switching on, restarted KODI and, again, played the same file. Result: Black screen.

Hope this helps. Please tell me if you need anything else.