HDR Banding issue


#194

Right good to know - were you using the sleep inside the one linser or just the echo?


#195

Just the echo line. I found it didn’t work consistently so I did as you suggested and made the script. There may be a need for the sleep variable so it would appear the script method is the best workaround.


#196

Ok thanks, Ill do some tests after dinner and see if I can make a beginner friendly guide until Sam figures it out :slight_smile:


#197

It may be figured out already.
With the kernel I sent you last night for testing, it did not work because I had forgot to push my changes :roll_eyes:


#198

:rofl: nice. Let me know when I can try again :slight_smile:


#199

Ok so basic guide for temporary automated banding solution:

  1. How to access the command line

  2. Create a script by writing nano banding.sh enter

  3. Paste these three lines in the editor (usually by simply right clicking) and then press CTRL+X, Y, Enter to save.

#!/bin/bash
sleep 2
echo round1 >/sys/class/amhdmitx/amhdmitx0/debug

  1. Install the Kodi Callbacks addon- in Kodi go Addons, Install from repository, Kodi Addons, services, kodi callbacks and install!

  2. After installing select Configure and add a ‘script’ task. Browse for script and select your new banding.sh (should be in home folder)

  3. Go to Events tab and create an event on Playback Started and make sure the task is “task 1”

  4. If you want to (you probably do) go to the General tab and make sure “Display notifications when task run?” is disabled

Press OK and you’re done!

If there’s still something unclear let me know :slight_smile:


#200

Nice write up! Maybe a reference to where to place the script. I made mine in /home/osmc. So the command would be “sudo nano /home/osmc/banding.sh” to create the script file.


#201

Thanks a lot! This did the trick, banding is now completely gone.


#202

Doh! Never mind, I see the reference in the screenshots lol


#203

Yeah I tried to keep it simple, that’s the default path when connected and then easy to find using browse :slight_smile:

Edit: added path description in instructions. Also, no need for sudo in your home folder :slight_smile:


#204

Makes sense. Great job


#205

I had no banding issues until Jumanji: Welcome to the Jungle which had pretty bad banding on some scenes with bright, sunlit sky.
Setup the Round1 command with Kodi Callbacks and it solves the problem
completely :+1:

Question is…
What is Round1, Round0 doing? I tested it last night with a bunch of UHD HDR test patterns and could see no differences either way.


#206

I followed these instructions to the letter, but I still have the banding issue. Also tried a reboot but still no dice.

Was there another update I needed to install to make this temp fix work? I haven’t installed anything except the latest automated OSMC update.


#207

What is your current version?
Provide grab-logs -A so we can check!


#208

Hi! No nothing else than latest version should be needed. As fzinken said, please provide logs.

If you’re connected via ssh and start a movie you can try

echo round1 >/sys/class/amhdmitx/amhdmitx0/debug

Manually to see if it changes anything.


#209

Thanks, @fzinken & @Martorias.

https://paste.osmc.tv/xaxejeluca

The banding is very obvious in the Fox logo intro to “The Shape Of Water”. Playing it back on my PC doesn’t show the same problem, although my PC isn’t HDR.

I did try running the command manually during the intro, but no effect.


#210

You are on the latest version.
Could you try cd /sys/class/amhdmitx/amhdmitx0 && sudo echo round1 > debug


#211

Enter that while the movie is playing?

Edit: nm. Tried it before I pressed play, and during. The issue still persists. It’s odd. Should I disable the Kodi callback before trying it?


#212

Yeah while it’s playing or paused i guess. Very strange. Disabling the addon shouldn’t matter.


#213

I found it was still necessary to have the 10bit forced command for this fix to work. Run “echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr” or place in /etc/rc.local first then reboot and try again. I know Sam had mentioned it should be automatic in the latest public update but I had to use it for it to work for me.