HDR Banding issue

I also see banding after the February update with onkyo amp and optoma uhd65 projector. Before wasn’t. I bought the Vero to avoid the banding that I had with the nvidia shield and now came back. I don’t get it instead to improve things you make it worse. I watch the Dunkirk for banding example on the start of the movie on the sky. On the info of the amp I can see I receive ycbcr 444 24bit.

I’ve reverted to the January image as banding was obvious with the Feb update.
My setup is Vero 4K > Marantz 7011 > Samsung UE55KS7000.
I’m using the “echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr” SSH method to obtain 10bit output.
With this my AVR reports 10bit (but it does for all files using this method) and my TV reports HDR and adjusts backlight etc accordingly for HDR media.
Just reporting for your info, so you aware of more users affected.
Looking forward to the fix, but more than satisfied with the performance of the January image for now.

Then you are still running in 8bit, you can switch to 10bit with the help of this thread.

I also have this pixelisation/banding with Yamaha RX-A870 and LG OLED B7 (10Bit Mode on Vero 4K enabled). Especially sky scenes are nearly unwatchable e.g. the beginning of Inception or La La Land.

I can reproduce this. Working on a fix.


I tried I put the line on the rc local but now when I play hdr I have blue screen. I have fiber hdmi that supports 18 gig transfer.

I reboot all the devices and now I have picture and is playing on 444 30 bits, but unfortunately still banding, I hope for a fix. By the way before the update I was still playing with 444 24 bit and I didn’t saw any banding.

Ok that’s good now your settings are fine, now we just have to wait for a fix, and Sam is working on it. If it’s absolutely unbearable you can reinstall with january release as a temporary fix

I am also experiencing the same problem with the Feb update and my 10bit 4K content running directly with Samsung 4K UHD TV. Thanks for working on the fix and will monitor this thread.

BTW for those who want to know what this issue is about below article from Netflix will help:

Sadly the just released March update did not solve/improve banding issues. Once again I can turn off the Vero4k and put it in the cabinet for (maybe) later use.

@mule this was always known, however the March issue did fix the flickering, deeply more annoying than the banding :wink:

There’s a new test build in the works that has some changes regarding dithering which should be available soon. Fingers crossed!

Needs testing, but

should let us make some further progress.

Take the latest staging kernel, and then you can enable/disable rounding and dithering via sysfs during playback. It will be interesting to know which parameters cause an issue


Thanks for your ongoing work and letting us know about the actual status. Although I did not have the impression that it is a dithering issue. Fingers crossed I‘m wrong.

I’ve also go the banding issue on 4k HDR files since Feb update.
Was fine before

Philips 65PUS7601 and Denon x2400H

The above needs testing so we can make progress.

I’ll put some instructions up shortly.


Am I right that we will be able to use the following commands in order to test dithering on/off and round on/off (between: What does “round” stand for?)

echo “dither1” > /sys/class/amhdmitx/amhdmitx0/debug
echo “dither0”> /sys/class/amhdmitx/amhdmitx0/debug

echo “round1” > /sys/class/amhdmitx/amhdmitx0/debug
echo “round0”> /sys/class/amhdmitx/amhdmitx0/debug

Yes – this should be the case. You can check dmesg to see if it’s working. If round/dither is not set to 1 then it is to 0.

These are the only two regs in my mind that will be problematic here.

Would be sweet to know what does what and how to test :slight_smile:

Either I’m doing something wrong or its not yet up in the repository (?) because dmesg gives no output after setting the debug parameter.