HDR content on Yamaha AVR and Samsung TV

#1

Sometimes it still doesnt detect HDR.

I have a Samsung Q9FN.
A Vero 4k+ and im on OSMC December 2018.12-1

Forcin updates says im on latest version.

So the problem is that it sometimes doesnt make the tv start the movie in HDR-mode. It is almost a 50/50 split of times it does start in HDR and it doesnt. Sometimes I can try it and it fails 3 times in a row and then all of a sudden the next times it locks perfect.

I remember there was alot of talk about this before so I just waited since I saw you working on it, but now its been 3 months and no update so I have just ask one question:
-Is there a setting for me to flip under Settings/System/Display ?

Right now im using default values so most things are off. I remember I had an HDR-flip here before but it seems to be gone now.

0 Likes

Post the July update - 4k HDR Content not identified by my Samsung 4K HDR TV
#2

Things should just work as expected now. Can you post a log?

Sam

0 Likes

#3

So I start logging, then navigate to a HDR movie and start and stop it numerous times - navigate back and get the link?

0 Likes

#4

Yes — please enable debug logging

0 Likes

#5

AS far as I remember it is a vanilla system with no edits in any of the config files.

I started the same movie 4 times and it locked on HDR 3 times and failed the fourth.

https://paste.osmc.tv/olubarodip

0 Likes

#6

Here is after a clean reboot and it failed first time and worked the second time:

https://paste.osmc.tv/getagejude

0 Likes

#7

Set adjust refresh rate to on start/stop.

0 Likes

#8

Hi. That didnt work. Still about 50/50 chance.

0 Likes

#9

Please post debug log where it doesn’t work, when Adjust Refresh Rate has been enabled.

0 Likes

#10

First and second try worked, but third try here didnt work: https://paste.osmc.tv/dazinodati

0 Likes

#11

Mar 17 18:32:04 osmc kernel: hdmitx: video: HDR data: EOTF: HDR10

We are sending the HDR10 EOTF. What makes you think HDR isn’t active?

0 Likes

#12

I can see it clearly right away. The tv is 1600 nits at peak white so it pretty obvious, but to be sure I always pop up the meny and the whites there are blindening, and It also displayes HDR or not in the menu.

There is no doubt when its on or off.

Ok so you cannot see anything different from the first 2 and the last start of the movie in the https://paste.osmc.tv/dazinodati -logs?

It is wierd since it is only from the Vero this happens, it never fails to kick into HDR from Youtube or Netflix.

Any ideas what to try?

0 Likes

#13

Is the Vero connected directly to the TV via HDMI? No amps, extenders, enhancers etc?

0 Likes

#14

Are these running on the TV’s internal apps or are you using an external device?

0 Likes

#15

They are internal apps yes, but HDR from the PS4 never fails either.

0 Likes

#16

It is connected to a Yamaha 3060.

I can update the firmware on the Yamaha, but from my point of view its only HDR from the Vero that ever makes me have to stop and restart content.

0 Likes

#17

I don’t know if it’s relevant, but you are not getting full HDR capabilities advertised on the EDID through the Yamaha. It seems it should pass through 4k50/60Hz and 4k24Hz at 4:4:4 but Vero is not sending that. Please check the Samsung is set to UHD Color On and that applies to the HDMI input you are using (HDMI4). Also, does the Yamaha have a setting for enabling HDR passthrough?

Is the PS4 connected through the Yamaha as well, or direct to the TV?

0 Likes

#18

see page 155 of manual. seems that mode 2 is default, try mode 1
is PS4 connected via AVR or direct on TV?
On Samsung UHD Color needs to be on, on HDMI 4 (ARC for RX-A3060) to be working in combi with mode 1 on AVR.

p155

0 Likes

#19

Good stuff here I will try it when I get home.

Yeah you are right, the PS4 is connected directly to the tv, I forgot about that, I did it to be able to get autodetect gamemode. I had everything through the Yamaha initially.

0 Likes

#20

@sam_nazarko @grahamh @mtv

I think it works now.

I found someone having the same problem on an Atv and this is what I did:

  1. Use the Yamaha Remote and choose the ON SCREEN button to acces the On-Screen section

  2. Go to the Set-Up section

  3. Now in the Set-Up section go to the VIDEO MODE section

  4. In the VIDEO MODE you will see 2 options :
    Option-1: Direct
    Option-2: Processing
    Now you would expect DIRECT to do NOTHING about your video signal and PROCESSING to convert it.
    However, the DIRECT does not work that way. It somehow processes the video and does not allow two-way communication between the component and your TV.
    So we have to set it differently.

  5. Go into the " Processing " section .

  6. There are again 2 options.
    Option-1: Resolution
    Option-2: Aspect

  7. Go into RESOLUTION , there choose " THROUGH " anything else will not work for this. After setting this, go back.

  8. Now check " ASPECT " it should also note " THROUGH " .

  9. Done

I succesfully started and got HDR from a movie 10 out of 10 so it really looks to be working now.

I also checked the mode and it was also indeed in Mode-2 so I set it to Mode-1. The movie started with HDR 10/10 still.

I want to be clear tho that from my side it definately felt like different OSMC updates made changes to me getting HDR on first try and for a long time I watched many many HDR movies and all of them worked, and then “suddenly” it didnt work anymore. I guess this is the wierdness of randomness and something to remember at next challenge.

0 Likes