HDR video won't play after latest update


I started to have issues playing HDR videos after installing the latest update today.

When I trigger the playback of 24p HDR video from a network drive, my vero4K+ stays stuck on the blue loading wheel and the playback never starts. Before the update I had no problem playing the same file with the September release.

Playback of SDR content looks to be working fine.

I also noticed that in the player settings, the option “Adjust display refresh rate” had no selected value. I tried to set the options to “Off” and to “Always” but it didn’t change anything.

I uploaded the logs here: https://paste.osmc.tv/rusokohihu
Media info for the file I tried to play: https://paste.osmc.tv/locetitesu.mel

Please check for updates again – this should solve the issue




After the 2nd update the playback works again.

A big thank you for your fast response and for all the great work!

I’m glad to hear this. You’re most welcome.


I usually use the option to “Adjust display refresh rate” on Start / Stop. But the “On start / stop” option is no longer available in the the Settings menu where the only options available are “Off” and “Always”.

I can still set it manually by editing the guisettings.xml:
<setting id="videoplayer.adjustrefreshrate">2</setting>

I hope that you’ll add the option back in the future releases.


I removed this as per the release notes.

We’re looking in to this internally as to whether this should be reinstated.

Can you clarify why you use the Start/Stop option vs Always?


I use a video projector and each resolution switch take up to 12s. So each time I bring the UI during playback I have no image for 12s. And when I get back to watch the video, no image for 12s again. With “On start / Stop” the transitions are seamless. The UI animations are not smooth during playback but I find it to be the best user experience.

We’re looking in to this and will keep you updated


1 Like


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Excuse my butting into someone else’s thread :slightly_smiling_face: but is reinstating the “on start/stop” option for this setting going to be the policy from this point onwards? I ask because setting this to an appropriate value is something that gets mentioned several times in my Whitelist HowTo, and I want to make sure the article is up-to-date…

Yes – it will be reinstated, so you don’t need to update your guide.

I already did. :rofl: But I’ll change it back at the next release! Do you have an approximate date in mind for when that might be?

Not just yet…

Hi Sam,

I followed your directions and tested the “Adjust display refresh rate” option this morning. The “On Start /Stop” is correctly restored and works as expected. Big thanks for that!

The “on Start” option was also restored and there’s an issue with it while playing a 3D videos:

  • the 3D Frame Packed mode gets enabled when the playback of an MVC video starts.
  • the Frame Packed mode never gets disabled when the playback stops. Even when the option “Disable stereoscopic 3D mode when playback ended” is enabled.

That said, I think that this issue has been around for a while.

I’ve restored the ‘On Start/Stop’ option and have pushed this to the release

We’ll keep this option.

1 Like