HDTV 720p50 playback problems (stuttering) with DVBViewer setup

That’s right. I have adapted the title.

Thx. I set up an environment to test again the timeshift to get a similiar scenario:

  • AVM DVB-C Dual-Tuner as SAT->IP server
  • RP2 B+, OSMC 2017.12-1, TVHeadend Server from the OSMC-Store, usb-connected HDD
  • Vero 4K, OSMC 2017.12-1, Tvheadend HTSP Client PVR, from the user add.on repository, active hardware acceleration

In between a simple switch network, both OSMC devices only have 100bt LAN interfaces but the RP2 has to process at least two streams: Input from AVM DVB-C and output to the Vero 4k.

As assumed timeshift is not a problem at all, no stutter. Forward and backward scrolling isn’t that smooth but I think this is actual a more general issue with Kodi.

Sebi issues are with DVBViewer but i also have the same issue with NextPVR. In the previously linked thread by Fzinken you can see Sam has acknowledged the issue and it has more details, but unfortunately the other thread was a general discussion that has morphed into a support issue.

The customer has submitted a returns request so I don’t believe they will be interested in testing any improvements.

After some digging today the problem can be reproduced. I’ll shortly advise the DVBViewer developer on how to resolve the problem. In the interim, I have a workaround and believe it will be beneficial for you as well @Andrew with NextPVR. Let me know if you’re happy to test this as I need a bit more feedback


Yes happy to help out @sam_nazarko , i may be a bit slow responding though as i have the Vero packed away at the moment and minding the kids today. But let me know and i will get to it throughout the day as time permits.

No problem – gives me a day or two to get on top of the Stretch migration before sending anything your way.



No problems, let me know when ready.

I can also test a workaround or hopefully a fix in the DVBViewer client plugin to provide some feedback.

Thanks Sam for the support :+1:

Hey Sam,

I submitted the returns request as the shop states I have to submit in during the first 7 days. 14 days for uk. As I’m located in germany I had no other possibility to request the return as the product is not working for me. Ofcourse I’m still interested in the product and if you fix the problem this week I’m willing to test and then decide if I keep the Vero4k.

Can you please describe in detail what the problem is? Is sounds as if the problem is not lying within Vero4k but within DVBViewer itself? Or is it the DVBViewer plugin?

Thx and BR

Hi Sascha,

I believe that the issue is caused by AMLCodec not knowing the frame rate of the video, so the decoder starts to get stuck. It would be interesting to know if setting a Fallback Frame Rate (http://kodi.wiki/view/Settings/TV/Playback) helps with this issue temporarily.


Perfect, it works if i set the “Fallback framerate” (German: “Standard-Bildwiederholfrequenz”) to 50 Hz. The channel is loading fast and I have no stuttering. It cloud be only a problem with different framerates. I only tested 750p50. I don’t watch other HD channel from DVB-C.

OK, that confirms my suspicions and lets me know what needs to be done.


Originally it was one of the first things i tried was to set the fallback framerate without success. But just fired up the Vero and updated OSMC and it now works fine with the fallback framerate set. So working fine here as well.

Out of curiosity I just checked my other devices with LibreElec x86 and codec info is showing as 0.000 FPS but is playing smooth and no fallback set. I have never bothered to look at it before as there was no issues.

Yes – looks like we need to give the decoder hints or add a frame rate when one is missing.

I think there may be a simple solution for this. For now, please try a new build. This will calculate a fallback framerate when we get no hints from ffmpeg. However the fallback not may be correct for LiveTV. Some testing with debug logging and the codec info output would be useful.

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


1 Like

Yes the problem is solved.

First I disabled the Fallback-framerate and updated the 4K as you described. I did some tests with different 720p50 HD channels and it works as expected.

There are my logs: https://paste.osmc.tv/mokixezuto

Thanks Sam

Thanks for testing and confirming that this is resolved.

If you run in to any other problems let me know.



Same results here as Sebi, so that part is working fine with fallback off. Thanks Sam.

I had other issues with LiveTV that look to be introduced with the December update, i will start another thread for that though.

Hi @Andrew

Thanks for confirming.
Let me know anything else that needs resolving and I’m happy to help