Hear left audio channel through both speakers

#1

Whenever I play music (maybe also video, but I’m not sure) I get the left channel through both speakers. I played the same audio file on my computer, and it contains and plays both channels. I tried the cd on my PS3 that is connected to the same tv with the same 2.1 speakers, and it plays both channels. That makes me think it is a pi/OSMC problem.

My pi is connected to the tv through HDMI. I reinstalled OSMC recently and didn’t do any config.txt modifications.

I set the audio device to ALSA, but that didn’t do anything. It’s now back on HDMI.
I set the audio channels to 2.1, but that didn’t do anything, so it’s back to the default 2.0
I set Stereo upmix on, but that didn’t do anything, so I turned it off again.
I set hdmi boost to 5.
I deleted hdmi_force_edid_audio=1 from config.txt

Any suggestions on what I could do to get both left and right audio through the speakers?

EDIT (2019-07-23):
Factory resetting my tv solved the issue (at least temporary). With changing the hdmi cable before, I also changed the hdmi input on my tv. It worked temporary, but it changed to dual left channel in some time. Other devices don’t do this. Something with my raspberry pi and OSMC makes my tv set the audio this weird. I changed the topic to unsolved again.

EDIT (2019-08-09):
So far, I can’t consistently replicate the issue, and although I’m far from sure, it seems like it only happens when pausing music, turning the tv off, and turning it back on again the next day.

#2

First suggestion: re-boot, play a stereo track and post logs.

1 Like
#3

Edit: Removed link

#4

Please turn on debugging and post full logs using MyOSMC.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

#5

I already thought that log file was very empty…

I looked at the log file, but I can’t make much from it myself. I found the music file opening at timestamp 11:36:05.502 T:1925468752

Edit: removed link

#6

Please provide the output of grab-logs -A. We prefer you to use our paste site paste.osmc.io so that we don’t have to connect to unknown sources.

#7

Thank you for trying to help. Sorry I’m not making it easy for you.

https://paste.osmc.tv/erukamevuq

#8

I’m stumped. Could you try setting the audio output to ALSA again, and posting logs from that, please?

#9

Sorry it took so long. I was very busy at work, and at home caring for my baby boy, so I could make time sooner. Anyway, here is the link:
https://paste.osmc.tv/yasacebara

#10

Longshot: Try turning off ‘Keep audio device alive’ and ‘Send low volume noise’.

#11

Still left channel through both speakers.
Also, when I go through the menu too slowly, the tv hud keeps coming up with each press on the remote, telling me I use hdmi1, and I have no sound for 5 seconds. Only when I go through the menu really fast I keep hearing clicks, and there is no delay in sound output. With other words, my audio device isn’t kept alive. I need this option on, but I can keep it turned off temporarily while troubleshooting.

#12

What is your setup? TV make/model? AVR? soundbar?

#13

Is there a chance to have a closer look at such audio file? Read that you have the original CD and play an mp3 file on the pi.

#14

I’ll try connecting it with a different hdmi cable to the tv, and with analogue audio directly to the speakers, to see if it makes a difference. I’m now off to work, maybe this evening I’ll have some time.

Sony tv, last year’s model, kd something €800. I’ll have to look it up soon.
It’s connected to a cheap (60, 70 euro/dollar ish) 2.1 logitech speaker set through regular stereo audio jack. Nothing fancy, but decent quality.

For you, unfortunately not, it would be piracy. The file is on a NAS, so I checked the exact same audio file on my computer, and it is stereo. It is how I know it is the left audio channel I’m hearing.

#15

Is the Logitech speakers set connected via a 3.5 mm audio jack?

Could you test with the TV’s built-in speakers and without the Logitech speaker set?

#17

Sharing media samples for the purpose of troubleshooting hardware/software issues is not considered piracy and is a legally protected act.

#19

I used a different hdmi cable, and I get both channels out. I have no clue how that’s possible with just copper wire and a digital signal. It shouldn’t be possible without electronics inside the cable. It’s the weirdest thing I’ve experienced in a long time. But I think it is solved.

I would like to thank you all for trying to help me. I appreciate the time you spend for me.

1 Like
#20

Extraordinary.

#21

It was not a permanent solution. I think it’s my tv. I need no further help on this matter, just wanted to include this as this could help others.

EDIT: I need further help. I still can’t play my music in stereo without resetting the tv. OSMC/raspberry pi is the only device that causes problems with my tv, so it is a OSMC/raspberry pi thing as well as a tv thing.

1 Like
#22

I bump this, as it is a problem from march, and I still haven’t found a solution. I don’t know if it is allowed to bump, but I found it necessary. I’m sorry if I broke forum rules or etiquettes.