HELP - Cannot revert to previous version of Kodi

I have read all the info that I can see on the site and am unable to revert to a stable version of Kodi and after trying to reinstall OSMC I think I might have bricked my device.

When I try to install the new version of OSMC from a usb the device looks as though it is loading then comes up with a fatal error saying it cannot locate the USB drive - “Cannot find root file system device”

I have tried inserting a match into the first hole next to the HDMI port to initialise the process but it still comes up with the same error.

The device will now not boot into OSMC at all.

Can a re-install be done through SSH?

Struggling here so any ideas welcome.

Can you try with an SD card?

And if there’s a file called install.log on the USB stick, please post the contents here.


Can you still connect via SSH?

I cannot SSH the device anymore, it does not show up on my network.

When you say SD card do you mean the micro one and would this be different to USB connection, at the moment I do not have this so would need to purchase.

To add when I installed the operating software on the USB it would only show me the SD card option, even though it did appear to write the software to the USB device.

Vero will look for the installation files on any micro SD card inserted first, then try USB.

The wording in the installer could be better, but from Windows and for Vero you just write the files to a disk identified by letter - it could be a card or a stick.

You could try reformatting the USB stick and running the installer again.

Hi Graham

Appreciate your very quick response.

I use a MAC and to my knowledge I checked the files and they look as if they have been installed correctly to the USB stick.

When this failed I re-installed onto another USB stick but same result.

If you think I will have better luck with sd card I will try and locate on and try that.



I don’t think it matters which USB socket you use, but have you tried both?

@mroebuck which version did you try and revert to?

yes I tried both and they both failed unfortunately.

Hi sam

I tried reverting to the last version, I think dated April 2019? but not quite sure.

April 2019 is the latest version.

You’ll know if the OSMC installer is running because you will see a very clear installation screen. Are you seeing this come up?

Can you show us a screenshot of the contents of your USB?


Hi Sam

When I power up the Vero it goes into a standby screen then immediately shows the following two screens with or without USB plugged in - apologies for quality as this is from a projector.

The contents of the USB stick are as follows.

Try with the October release instead


Hi Sam

Yes that worked, I have now updated and am on latest version of OSMC and Kodi so all looks well.

Thanks for the support.