Help Me Understand kodi.log Entries

The Kodi Log on my Vero has dozens and dozens of entries like this:

05:26:00 T:1647789088  NOTICE: service.libraryautoupdate-0.9.7 : Starting network check
05:26:03 T:1647789088  NOTICE: service.libraryautoupdate-0.9.7 : Network down, not running

(454 Network down entries in 12 hours)

and like this:

05:25:09 T:1589068832   ERROR: Unable to open database: xbmc_video90 [2013](Lost connection to MySQL server at 'reading initial communication packet', system error: 104)

(57 Unable to open database entries in 12 hours)

I also run Kodi/OSMC on a Raspbery Pi B+. It’s kodi.log has no such entries.

The Vero is using the built-in wireless, the B+ is wired to an Airport Express.

What’s going on?

Try run this command when you boot up:

sudo iwconfig wlan0 power off

Would be interesting to know if power saving is doing this. I have plans to turn it off for most WLAN adapters in the next update

FYI, we move to kernel 4.x soon for Vero. One of the i.MX6 kernel developers jnettlet comments that 4.x’s Broadcom driver brings much improved WiFi stability.


I turned off the wireless adapter and went back to using an Airport Express instead.

That stopped the Network down messages, but the Unable to open database messages persist. Once again, I do not see those messages on the Pi B+.

Incidentally, using the Airport Express has eliminated the WiFi throughput problems:

  • Browsing video libraries is now very snappy
  • I can now stream 720p videos with no buffering

It’s a shame that Vero’s WiFi throughput wasn’t thoroughly tested before releasing the product.

As you know, I’m not a happy customer.

I stream 1080p from two rooms away.

Also, if you arent going to do what Sam asks, then why would you expect any more support from anyone else?

I’m tired of fiddling with it. This is not a hobiest’s toy, it’s a commercial product that should work as advertised out of the box.

It’s Sunday. My family wants to watch TV, not have me do endless command line diddling. I deployed the Airport Express so that they could have some non-buffered entertainment. I apologize for putting my family first.

When I have time and everyone else is at work or at school I may be inspired to turn the wireless interface back on and play with it.

The fact that you can stream 1080p through two walls seems to be ample demonstration that my Vero may be defective. I can also stream HD video through two concrete walls – using a Pi B+ and an old AirPort Extreme.

Did I ask for extra support? Not that I recall. I just want a product that works. I did extensive testing with iperf to demonstrate my Vero’s WiFi inadequacies. I’ve also provided log files.

Instead of real customer support I either get snark or get ignored. This is not the way to treat paying customers.

You wont run a single line to try and fix your issue?

You literally wrote 50 times that much in your response.

Do you actually want the problem fixed, or do you just want to moan?

If that line is too much for you, then go to MyOSMC - Updates - Manual Controls - Apply Hotfix, and enter this: [deprecated]

To reiterate, the WiFi signal is not going to magically improve, but the connection stability should improve with our next kernel release.


I said I’d do it when my family was no longer using the Vero, and I will. I’m not going to interrupt their viewing for this.

Tomorrow is Monday. I’ll be home alone.

Do you have that much patience? I do.

Last login: Mon Jul  6 08:21:32 2015 from
osmc@osmc:~$ sudo iwconfig wlan0 power off
sudo: iwconfig: command not found
osmc@osmc:~$ which iwconfig
osmc@osmc:~$ sudo apt-get install iwconfig
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package iwconfig

Before you scold me again, please have a look at my posts in this thread which, I believe, demonstrate that I am willing to spend some time and take some trouble to work this out:

As for yesterday, you berated me for responding to a post but note being willing to “run a single line”. At that time my family was using the Vero to watch videos. I was not watching. I did have time to respond to this thread, but I was not willing to ask them to stop watching TV so that Dad could reconfigure the network and reboot the machine.

Keep in mind that not all of us are full-time geeks. Some of us have actual lives to live and families to care for.

Thats fine, but you responded to Sam’s suggestion without even a single acknowledgement of it. No, “I will try that” or anything. But you did manage to find the space and time to reiterate a prior complaint.

I thought that my explanation that I had disabled the WiFi adapter and deployed the Airport Express was response enough.

Anyway, as you can see, I can’t run Sam’s suggested command. Although, try I did, as promised.

And, since Sam has confirmed that the WiFi signal cannot be improved, there’s really no point in going on.

The Vero works fine wired to the Airport Express. I’m sorry that I wasted so much time fooling with the built-in WiFi adapter. I should have deployed the AE sooner. Less hassle. Less grief.

I am, however, still curious as to why you can stream 1080p video through two walls and I can’t even stream 480p (with the Vero on WiFi) three meters through a quarter inch thick wooden stereo cabinet.

Keep in mind that I can stream 720p video to

  • An Apple TV which sits right above the Vero
  • An iPad anywhere in the house
  • A Pi B+/Airport Express separated from the router by 10 meters and two concrete walls
  • The Vero when wired to an Airport Express

There has to be a rational explanation as to why yours works and mine doesn’t.

“sudo apt-get install wireless-tools” should give you iwconfig

When you respond to someone without addressing what they just said, you cant complain when people think you are ignoring them.

I suspect I can stream through two walls because they are simply timber framing and plasterboard, here are no wires or pipes running through them, and there is nothing else around that can cause interference.

Now, this is odd. I was away from home for a while. When I got back the Vero had lost the wireless connection. I was unable to SSH in. Had to cycle the power for it to acquire an IP address.

Thank you. That worked. I have now executed the requested command.

That really doesn’t explain it. I suspect that your Vero is more than three meters away from your router.

I’m only three meters and the only barrier is a thin piece of teak on the end of my stereo cabinet.

You can stream 1080p and I get buffering with 480p.

It makes no logical sense.

You mean kind of the way you responded to me but ignored the important part of my post where I showed that the iwconfig command wasn’t installed on my Vero?

Pfft. Hardly. I dont know jack about networking. What am I going to do? Tell you to try turning it off and on again?

Quite frankly, I dont give a shit about your wifi, or about any problems you are having. It’s not my
department. But you were offered a potential solution and you ignored it completely to keep on complaining.

How about you go back and look at your post, the one right after Sam’s. Notice how you didnt even respond to a single thing he said. People who do that sort of thing are showing everybody that they care more about complaining, than solving their problem.

So, the only reason your posting in this thread is to complain about my behavior?

Brilliant use of your time. At least it’s been entertaining.

Disabling the wireless power management has eliminated the log messages referred to in the OP.

However, throughput is still inadequate. So, I’m going back to using the Airport Express.

While I am pretty sure you can get well bent pal, at least we can both agree that your behaviour was deplorable.

Thanks for that – I will make the power saving disabled by default in the future and hope kernel 4.x with the new Broadcom driver can bring some improvements too

Let’s keep the tone civil chaps…