Help mounting NFS


i’ve recently upgraded to the new vero and a new WD Mycloud home network drive. I’m trying to mount it with autofs like my old drive but having no luck. Could anyone help me please?

I’ve tried /mnt/<MyCloud- 0U1ZMK> <>:< Public> or /mnt/<MyCloud- 0U1ZMK> <>:<NFS/Public> the old drive firmware told me the NFS point needed NFS/Public but looks like on the my cloud home western digital had stripped out all the firmware features so theire isn’t really a UI with any settings. The new drive works fine in windows. Is there anyway i can confirm the mount point or anyway to get it working in general. I do love these vero devices but connecting to a network drive seem to always give me a lot of pain.

kind regards

Windows would use CIFS/SMB!
Did you activated NFS on the MyCloud?

Run showmount -e and post the output.

osmc@osmc:~$ showmount -e
clnt_create: RPC: Unable to receive

WD don’t give you any option to do anything

I’m half way towards the idea of just selling the drive and getting a Synology DS120j 1 Bay Desktop NAS Enclosure, would that be better?

Then use autofs with smb/cifs instead of NFS. I assume MyCloud doesn’t support NFS.

Thanks I’ve had a go with
/mnt/< MyCloud-0U1ZMK>/< Public> -fstype=cifs,rw,credentials=/home/osmc/.smbcredentials,iocharset=utf8,uid=osmc,gid=osmc ://<>/< Public>

but no luck does that look correct?

Install smblient sudo apt install smbclient

And show output of
smbclient -L

Have you created that file with correct details?

i got
Sharename Type Comment
--------- ---- -------
Public Disk
TimeMachineBackup Disk
Dave Disk
IPC$ IPC IPC Service (MyCloudDevice)
SMB1 disabled – no workgroup available
I believe i added the correct credentials, i used the local user one set up on the device which reading online said should be the SMB ones as well.
what now? am i getting close, thanks so much for your help

Well you where on the right way.

  1. In your config you have to remove the < and > those were only meant to show what need to be replaced with customer data.

  2. The share is called Public Disk not Public. So instead of Public you would need to Public\ Disk.
    The \ is needed because of the space in the share name.

Details can be read in the guide

1 Like

Still no luck tired with public and public disk. is disk in the name if it was listed in the type column? could it be the version i need to change as listed in the guide?

OK so it is Public

Can you show the config you used?

tried this

Looks ok if the credentials file is correct and has correct contents.
Suggest to try the debug step as explained in the How To

It’s hard to see but do you maybe have a space between /home/osmc and .smbcredentials

Oh thanks I’ve added ,ver=3.0 and it’s working! Thanks so much for your help!


@DaveLamb i will buy @fzinken a beer.