Help please for beginner who cannot play video files

Just received my 4k and need a bit of guidance please.
Device is plugged into TV, powered on and everything is working as it should. DHCP address is correct for my lan and I have updated firmware and am ready to try videos but…

My videos are stored on Qnap NAS and streamed by Twonky on the NAS. (The files are also shared as NFS). I can get as far as the directories for the videos using UPnP devices route or NFS route but cannot see or play the contents. The videos are all .mp4 and play on my OSMC on Raspberry Pi. What have I forgotten? Are there libraries/codecs that I should have downloaded?
Sorry to be so dumb.

I would check this

If you still have problems provide debug enabled logs

It sounds like you just need to add the directories as sources. I think the NFS layer is working OK if you can see the directories.

This might help: [Wiki] Noobs guide to Kodi

1 Like

Hi and many thanks for the speedy reply. It looks like a permissions thing although I cannot yet be sure. I have just dug out my RPi and am updating as I type. Will see how that was set up.

Meanwhile I note the preferred file sharing system is NFS and mounting the remote directory but when I tried to set up fstab I had a message saying that fstab was no longer used. Is there an updated method or do I go ahead with fstab?

You could restore a backup from Pi to Vero 4K via My OSMC.


Where did you find that message?
Or you mean the comment within the fstab file?

Hi and first my apologies. Grahamh was correct, I had not added the directories as sources. All is now OK and both NFS and Twonky shares are working.

I thought I would try and have the NFS files mounted as suggested in the above link (configuring-fstab-based-nfs-share-mounts). BTW where are the buttons for highlighting Code? Meanwhile when I run:-

sudo nano /etc/fstab

I get:-

  GNU nano 2.7.4                                    File: /etc/fstab                                              

# rootfs is not mounted in fstab as we do it via initramfs. Uncomment for remount (slower boot)
#/dev/vero-nand/root  /    ext4      defaults,noatime    0   0

Again please forgive the absence of [CODE] brackets etc. still learing the ropes here.

Of course I can go ahead and edit fstab but will it be run with normal startup?

I fixed that for you for code I suggest you mark the text and use the buttons </> and " from the menu above the editor page.

Yes go ahead, that should work fine. The comment in the fstab just relates to the root file system which now is mounted via initramfs.

Hi and many thanks. Will set that up along with other “housekeeping” items including passwordless ssh login.
I do have a couple of other questions and should start new threads when I am ready but my main concern is provision of firewall. Will read up other threads on this before I post. If you have any recommendations please let me know.
Thanks again,

Keep it behind NAT and it shouldn’t be a problem.

Hi Sam and thanks but I would like to return to firewalls later.

Read up on iptables and check out fwbuilder

Hi and thanks for the suggestion. I have read up on these and also ufw. I have also read some of the threads here on firewalls and security: Clearly the best advice is to have all devices which do not need an internet connection on a separate lan. However constraints due to cable infrastructure and access mean that I shall have to use vlans to achieve this with a couple of managed switches at strategic cabinets and it will take me a while to get my head around this and the long term objectives.

Meanwhile I still believe a basic firewall would be a good thing. I note and accept Sam’s comment elsewhere that the subject of firewalls generated difficulties for the forum but I do believe a simple guide should be available in the wiki or somewhere similar. There is a useful guide on the Raspberry Pi Documentation>Configuration>Security but it may need updating.

My particular problem, for example, is that having set up key based authentication and installed ufw, if I try and start ufw I get a warning that will lose my ssh connection but when I try and add “allow ssh/tcp” I get “Skipping adding existing rule.” Also there is an example of how to allow access through a particular port but no advice as to which ports to open for particular purposes.

For a multimedia device like the Vero 4K which may be using UPnP and may for some users require Internet access having to read the various reference documents is quite daunting and I suggest a few basic defaults would be helpful to get going even if they need editing later.
Thanks again for your suggestions.

Maintaining any OSMC device behind a modern router which is not configured to forward any incoming ports to the OSMC device will be more than sufficient for 99% of users. Anyone who wishes to configure otherwise should inform themselves of the associated risks and best practices when doing so. Providing security instruction for someone willing to take security into their own hands is outside the scope of this forum and the product’s intended use-case.

Thanks for that. Always appreciate constructive comments from knowledgeable users.