Help request: Correctly setting up SMB server for Windows 10

For the benefit of other people with issues:

First thing I did was a clean install of OSMC, and reset all sharing preferences to the folders in question.

Then I created a local Windows 10 user called osmc_share with password osmc

I then set the permissions for external drive G: as follows:

Once the name was checked, I clicked OK and set full permissions for osmc_share


Then I gave permissions to osmc_share for each individual folder



Then I used MobaXterm to SSH to osmc@<IP address> where <IP address> is the address of the Raspberry PI on the network

sudo nano /etc/fstab

Down arrow key for new line and paste the following:

//<IP address>/G/TV    /mnt/TV    cifs    defaults,vers=3.0,username=osmc_share,password=osmc,x-systemd.automount,noauto   0       0

There the <IP address> is your local Windows 10 machine

thanks JimKnopf

Enter key

sudo mount -a
sudo systemctl daemon-reload
sudo systemctl restart
cd /mnt/TV

You should now be in the folder TV and using ls will show the files inside

To set the folder up in OSMC, go to Videos, Add videos, the location to enter is /mnt/TV/

Then follow the prompts for various media viewing options.


Hi @Khal_Doggo,

you could even try protocol vers=3.02 with current Windows 10 and OSMC.

Hi, thanks. What would be the benefit of switching to 3.02?

It’s a more actual protocol but not the latest. :wink: