Help request: Correctly setting up SMB server for Windows 10

I’m currently trying to set up OSMC on a RBPi and would like to stream from Windows 10

Let me just say that I am aware that my problem is not new and that this is a similar thread to many others. But the others haven’t answered all the questions I have and I am still lost.

Steps I have taken:

*Shared the relevant folders and the drive (an external HDD in Win 10)

*Removed password sharing in Network Config (Win 10)

*Made sure my AV/Firewall isn’t being screwy - I’m using BitDefender

Problems I am having:

*Unable to browse SMB on OSMC - I know that there are problems with browsing on Win 10

*Unable to set up specific folders.

For example:

My PC name is ‘ASGARD’, the external HDD is the G: drive and the folder is called ‘TV’

Entering “smb://ASGARD/TV” into ‘Add Network Location…’ in OSMC yields ‘Connection time out’.
The same thing happens with “smb://ASGARD/G” or trying lower case etc
My workgroup is just called WORKGROUP

Through going into the various forums, I keep coming across the advice to use fstab or edit an .xml file. The issue with that is I don’t know how to properly format the fstab, and I’m also not sure what to put down for any SMB username and password - I am logged into Windows 10 using a ‘’ account.

Can anyone offer some help? I’ve tried youtube tutorials too, but all those can simply browse for their folders of interest.

Have you tried using fstab mounts?

1 Like

Password less access can be broken, suggest to create a local user to access the shares.

Use IP address instead of Computer Name, it’s more reliable

Thanks, when you say:

suggest to create a local user to access the shares

Do you mean create a windows user profile on the PC?

Yes, a user/password on the Windows Machine that you use to share

I created a Windows user called ‘osmc’ with password ‘osmc’

Here is the full line I have entered into fstab:

//IP/G$/TV /mnt/TV cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=osmc,password=osmc,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Running through:

sudo mount -a
sudo systemctl daemon-reload
sudo systemctl restart
cd /mnt/TV

I get the error:

-bash: cd: TV: No such device

Running the command:

osmc@osmc:~$ smbclient -L <IP address> -U osmc%osmc


Connection to <IP address> failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled -- no workgroup available

So you have entered the actual IP address of your Windows machine instead of <IP address>

That’s right.

I have made sure the SMB Client is available in ‘Add Windows Features’. I have also checked to make sure NetBIOS is enabled and that the service is set to run automatically in ‘Services’.

At this point, I’m just ready to give up.


Error is referenced in the wiki:

Tried this, didn’t work, sadly. Note that I am not using guest access, I am trying to access as a Windows user I created with Administrative rights named ‘osmc’


I was more referring to the vers=1.0 flag. Could you please you please provide debug logs showing your current configuration.

Thanks Tom.

Hi, yes sorry, I am at work so will try get the logs up later.

I used the fstab call with with the vers=1.0 flag and without it. Both cases resulted in the same error, as above.

I’m reaching a point where googling my problem results in very old posts from around 2009. Nothing pertaining to Win 10 specifically. In addition, no one seems to have resolved the problem:

Connection to <IP address> failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled -- no workgroup available

All the threads I can find which discuss it die out with either no replies, or an incomplete solution which fails.


I don’t think its accepting your username, try:

smbclient -L <IP address> -U osmc

I think it will then prompt you for a password.

Thanks Tom.


Thanks, I tried that too last night. Same deal. Whether I include the password or not, I get the same error after any password prompt. I also tried specifying the workgroup name and also using the version flag in this call, those were the only flags that seemed relevant in this case. In addition, I tried to use //ASGARD/ instead of the device IP. Each time same error.

Essentially I get a list of the detected samba shares and then the same NT_STATUS_… error and a NetBIOS / no workgroup message.

So you get the list of the shares? You didn’t mentioned that early!
Can you show us the full output instead of just bits and pieces?

osmc@osmc:~$ smbclient -L <IP address>
Enter osmc's password:
OS=[Windows 10 Home 17134] Server=[Windows 10 Home 6.3]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    G$              Disk      Default share
    H$              Disk      Default share
    IPC$            IPC       Remote IPC
Connection to <IP address> failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled -- no workgroup available

Those are just the “system hidden shares”, there is no sign of a folder you have shared to the osmc user(osmc on windows box).

Which is why I didn’t bother to post them in the first place, but the above person said to post the whole output. I’m trying a fresh install of OSMC and if it doesn’t work, I’ll just set up Emby

Hi @Khal_Doggo,

I took your example and got it to work in my environment:

  1. You need to give sharing access to G$ AND directory TV for local user osmc within Win 10
  2. You need to change the fstab-line from //IP/G$/TV … to //IP/G/TV …since the sharing name for G$ is simply G for normal users. The concept to use concatenated sharing names is not clear to me but I simply document how it works. I would use //IP/TV ... instead which makes it much more simple.
  3. You need to specify the 3.0 cifs protocol in your /etc/fstab so let start the option list with vers=3.0,x-systemd.automount, …

So, here the example which works in my setup with Win 10:

//    /mnt/purgeme       cifs    defaults,vers=3.0,username=osmc,password=osmc,x-systemd.automount,noauto   0       0

You are an absolute bro. I feel like I owe you about a dozen beers