Help required to recover vero4k


#1

I had been using the 4k and thought things were running pretty well on the LG OLED - the only slight sniggle I had was the frame skip. I had been sitting on the October update and tried an update to the December version. This cured the frame skip and things were smooth as silk.
On the down side the banding was back and it was massive (on playing all media). Dark areas were absolutely terrible and blue skies look crap to be frank.

I followed the instructions to downgrade back to the previous october version.
https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

I tried it just on the ubb stick and repowering but notihing happened.
I then followed the troubleshooting guide and tried it with the button bush for 30 seconds but again it stuck on please stand by.

Finally I tried the rename the file to recovery.img

Again nothing is happening - its stuck on this screen.

The instructions are not 100% clear as the downloaded file name is OSMC_TGT_vero3_20181101.img.gz

Do I need to change it to recovery.img
or
recovery.img.gz

Please help as I have an expensive brick now that will not boot up.


#2

You need to use the OSMC installer which will write the image to the SD card or USB stick.
At the moment the stick isn’t prepared correctly so OSMC is not booting from it.

Sam


#3

Thanks for that - Didnt read the recovery instructions properly.

I downloaded the installer - it grabbed the image and asked where I wanted to save it.
Everything is greyed out -even with the USB in place.
SD card was selected but greyed so I attempted to continue - it saw the USB and installed to USB.

Plugged into vero4k and it started booting up only to end with an error regarding the USB location not been seen.

Any ideas?


#4

What files do you now have on the USB stick?


#5

Indeed – please take a screenshot of the contents of the USB stick and a picture of the error you’re seeing.


#6

here are the contents of the usb and the greyed out screen where you are meant to pick your destination.
Cant get the f’n vero to boot now it keeps either no video output or it sticks at the please wait icon.

Should i try the rename kernel to recovery and try that?


#7

The options are greyed out because you always install OSMC on internal storage on the 4K / 4K +.
You could try renaming to recovery; alternatively try a different stick or micro SD card.

Sam


#8

Finally got it back.
To say it was a chew was an understatement. 3 usb drives and none will get picked up by vero4k.
Ended up having to use an old mobile phone with a microsd card and passing the files onto that.

Got a picture and thats as far as i’m going today. Need a beer!

Thanks for your help so far.


#9

Glad you got it going, but there’s nothing in the December update that should affect banding. We’d like to get this fixed for you or you won’t be able to move onto Kodi v18 (coming soon).

We would need you to upgrade again to December and upload debug logs. And describe your video chain - AVR make/model, TV make/model.


#10

Im now back onto the latest December build and seems pretty good so far.
I have tried quite a few titles and they seem about right - the only one so far that has shown bad blocking/pixelation is the TV series “The Bodyguard” .
Having done some more poking about it may be an issue with the TV as there seems to be some reported problems of the same nature getting reported in dark areas. LG seemingly know about it and expect a resolution in the first half of the year. Speak about not committing yourself.
I have tried the same media clips through the vero 4k and directly through the hard drive to the TV and the banding/blocking issue still arises so it clears the vero from being the culprit.

For the time being im going to quit while im ahead and thanks for all the help and pointers to get things back working again.