Help, sad face luup after update to v17

Please help I updated to v17 and after reboot I have sad face loop.
Here is my log http://paste.osmc.io/dufidesuwu

18:00:37.517 T:1958683568   ERROR: SQL: [Addons27.db] SQL error or missing database
                                            Query: SELECT idVersion FROM version
1 Like

Thank you for this advice. Mine was called Addons27.db which was size 0. As soon as it was deleted osmc recreated the file and all is working good now.:slight_smile:

Enjoy!

1 Like

Thanks, deleting all old .db files fixed the problem.

I had this as well so thanks for this thread. Deleting Addons27.db worked for me.

Hi @gizzalucy. Probably an absolute noob question but having the same problem (sad face loop after update) and wondered how you deleted the addons27.db file? Did you do this via windows? As in by putting the SD card in and open the database folder and delete and delete the file?

Thanks :slight_smile:

Access OSMC via SSH (putty) than you can delete files

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Here is a cheatsheet for how to navigate in a Linux shell: Cheatsheets and Tutorials for users new to Linux based operating systems

Thanks a lot mate, ill read them and give that a try :blush:

I did it via a remote connection (ssh) using the Linux rm command. rm is the delete command.

As fzinken says you have a bit of learning to do.

Use a free Windows program called putty to login to your pi over the network. Then you have to type in commands to delete the file.
I did it this way:

cd .kodi/userdata/Database
dir -l
rm Addons27.db

Capitals are important. Addons27.db could be any number, that’s why I used the dir -l command (Iower case L) to list the files.

1 Like

Thanks @gizzalucy. Really appreciate the help guys, will give that a try later on tonight.

Or you can install program called winscp that let’s you broswe through osmc folders and delete. can also drag drop files from PC to osmc. Much easier

1 Like

Hello,How do i find my osmc ip address from my laptop? Thanks

Check the webpage of your home router. It should indicate which IP address was handed out by DHCP.

If you have an android phone try Fing. Very useful app that will tell you lots of info about your network.

1 Like

Thanks all. Manged to delete addon27.db file!

I got the Isp from router home page :relaxed:

Used the winscp tool to search the name and it came up pretty quickly and then I was able to delete and all is working well.

Thanks all!

1 Like

thank you it solved also for me

Solved it for me also - Phew!

thank youuu !