Help with 3d mkv playback issues ff/rew

I have two Vero 4K+ and they both have issues with some 3d mkv files when I try to FF or Rew. The video goes black and then I need to cycle power on the Vero 4K+. And after this happens playing back again at that point usually fails as well. Only a small percentage of my movies have this issue and they are usually foreign titles. Hobbs and Shaw is one of them.

A second problem is a few movies are 3d inverted, Edge of tomorrow, Hobbit Desolation of Smaug. I haven’t been able to find a menu option if there is one to switch the right and left frames. What is the best way to fix this? Minor issue because I found a way to switch on my projector but not on my tv.

I am very new to Vero4K+ so perhaps what I’m doing is not correct but basically I have a PC Plex server streaming the 3d mkv ripped files using MakeMkv and have the Vero 4K+ using the Plex app for playback. Is this supposed to work reliably? Wired Gigabit Ethernet connection.

The ability to have 3d mkv playback is working very well for the most part and I do love being able to do this with the Vero 4K+. My biggest issue is the FF/Rew issue.


Can you post some logs of this?

How are your shares mounted?

I know that ISOs can be problematic for seeking because of how they are structured, but ISOs shouldn’t be a problem.

I will work on providing logs for this issue. Shares are not mounted, I’m using Plex to stream to the Vero 4K+. Not sure if that is supported or not but it does work for me for the most part except for a small percentage of movies.

Is the preferred way to playback 3D using mounted shares?

Thanks for your help.

I duplicated the problem with logs enabled and uploaded the logs to . Tried to FF while playing Hobbs and Shaw in 3D via plex.

Also found when playing and stopping playback of Abominable in 3D. Started playing again (after exiting and playing a different 3D movie and going back to Abominable) caused it to crash, no FF/Rew needed to crash.


It’s late here – so I may have missed it, but your log doesn’t seem to show any playback attempts.



I just wanted to throw some info into this topic that might not at all be related but I still want @sam_nazarko to know.

The crashes that usually occur only when chapter skipping files with Dolby TrueHD tracks while having TrueHD passthrough disabled do also occur if using the left/right arrow buttons on the OSMC remote to jump 10s, 30s etc. when using the official Plex add-on. I noticed this a couple of weeks ago when I was testing the add-on. So while the crashes are limited to chapter skipping when using plain Kodi, they are not limited to only chapter skipping when using the Plex add-on.

@2ndvizio Would you mind checking if the 3D movies where the crashes occur have a Dolby TrueHD (Atmos) audio track. Also please check if you have TrueHD passthrough enabled or disabled in the Audio settings.

Does the log get reset on power up? If so, it could be that I need to restart the Vero4K+ when this happens and the log gets lost. Or perhaps it starts a new log on each power up, in which I case I should have uploaded the previous log instead.

@ainsley Abominable and Hobbs and Shaw are both TRUEHD 7.1 Not sure if that means Atmos or not, I have an old 5.1 receiver and connect via Optical so I haven’t been keeping up with the latest audio formats. Audio settings for TrueHD passthrough should be the default.

Good to know that what I’m seeing with the Plex add-on is reproduced elsewhere.

So if I use plain Kodi and do not do chapter skipping, then things will work without crashing? Does plain kodi mean mounting the drives and playing back directly using the Video player? That might be a good workaround until this issue gets resolved with Plex addon. Thanks.

Just to clarify. Dolby Atmos is either Dolby TrueHD + additional metadata or Dolby Digital Plus + additional metadata.

First, can you check if you also experience the crash when playing a 2D file with a TrueHD audio track?
If your audio settings are default, that should mean that TrueHD passthrough is disabled, which makes it more likely that the problem I described is what you’re experiencing.

If you want to use Plex to manage your media and update the watched status etc. you can try PlexKodiConnect which many people think is better than the official Plex add-on. It uses Plex only for the backend, but still uses everything else from Kodi.

I wouldn’t get my hopes up too high because this issue has been around for some time and AFAIK it is not an OSMC issue but rather a Kodi issue. And according to this, it is not even being worked on atm.

If your TV is capable of decoding TrueHD tracks you could consider connecting the optical cable from your TV to your AVR. Then you could enable TrueHD passthrough and the problem should disappear. Of course then you would lose any surround capabilities because your TV will send a PCM stream to your AVR and optical cable only supports 2 channel PCM sound.

There is a guide for audio related settings.

Yes if you use the default Kodi player (which is also used when using PlexKodiConnect) then it should only crash on chapter skips (pressing up/down on the OSMC remote).

Unless its a combination of 3D and TRUEHD being disabled, its unlikely that I’m seeing the same issue as I don’t have any problems playing the same 3D movie in 2D mode.

PlexKodiConnect seems interesting but something for the future for me, I don’t have time to mess around with modifying the Vero4K+. Rather just stick with the standard releases.

So it seems like the easiest workaround is to run Kodi in file mode and mount the drives on my PC. The majority of the 3D movies play back and ff/rew just fine, its just you don’t know which are the ones that don’t work and unfortunately the Vero4k+ doesn’t seem to do a watchdog reboot but just crashes instead. But I’ve got it plugged in to a Alexa controlled switch so now I can get back up and running quickly after the crash.