Help with autofs with Synology & QNAP NAS-es

#1

So, I have a new Vero 4K+ and I’ve been trying for over 2 hours to set-up autofs to do OS mount, and failing… (I have a Synology 1812 NAS and a QNAP 431P NAS.

I followed instructions exactly as written up here (the main part, not the addition at bottom by @ bgregson), but below happens. What am I doing wrong? Prior to below I successfully did sudo apt-get install autofs (or so I believe, right, as I wouldn’t be able to do sudo nano /etc/auto.master w/o it)…

cap1 cap2 cap3

#2

What is the output of systemctl status autofs.service?

Please just paste it on your post using the code tag </>. Screenshots are resource hogs and more difficult to work with for you and us.

#3

login as: osmc
osmc@192.168.1.247’s password:
Linux osmc 3.14.29-155-osmc #1 SMP Tue Sep 3 19:35:46 UTC 2019 aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Sep 5 18:01:32 2019 from 192.168.1.180
osmc@osmc:~$ systemctl status autofs.service

  • autofs.service - Automounts filesystems on demand
    Loaded: loaded (/lib/systemd/system/autofs.service; enabled; vendor preset: e
    Active: failed (Result: resources) since Thu 2019-09-05 17:33:46 EDT; 1h 10mi
    Process: 4442 ExecStart=/usr/sbin/automount $OPTIONS --pid-file /var/run/autof
    Main PID: 4162 (code=exited, status=0/SUCCESS)

Sep 05 17:33:46 osmc systemd[1]: Starting Automounts filesystems on demand…
Sep 05 17:33:46 osmc automount[4442]: /usr/sbin/automount: program is already ru
Sep 05 17:33:46 osmc systemd[1]: autofs.service: PID file /var/run/autofs.pid no
Sep 05 17:33:46 osmc systemd[1]: Failed to start Automounts filesystems on deman
Sep 05 17:33:46 osmc systemd[1]: autofs.service: Unit entered failed state.
Sep 05 17:33:46 osmc systemd[1]: autofs.service: Failed with result ‘resources’.
lines 1-12/12 (END)…skipping…

  • autofs.service - Automounts filesystems on demand
    Loaded: loaded (/lib/systemd/system/autofs.service; enabled; vendor preset: enabled)
    Active: failed (Result: resources) since Thu 2019-09-05 17:33:46 EDT; 1h 10min ago
    Process: 4442 ExecStart=/usr/sbin/automount $OPTIONS --pid-file /var/run/autofs.pid (code=exited, status=0/SUCCESS)
    Main PID: 4162 (code=exited, status=0/SUCCESS)

Sep 05 17:33:46 osmc systemd[1]: Starting Automounts filesystems on demand…
Sep 05 17:33:46 osmc automount[4442]: /usr/sbin/automount: program is already running.
Sep 05 17:33:46 osmc systemd[1]: autofs.service: PID file /var/run/autofs.pid not readable (yet?) after start: No such file or directory
Sep 05 17:33:46 osmc systemd[1]: Failed to start Automounts filesystems on demand.
Sep 05 17:33:46 osmc systemd[1]: autofs.service: Unit entered failed state.
Sep 05 17:33:46 osmc systemd[1]: autofs.service: Failed with result ‘resources’.
~

#4

That post you followed did not have instructions for SSHFS on the automount. If you do a web search I think you will find the setup is a bit more than just swapping the name of the protocol. Is there some reason why you can’t just use NFS? I don’t think you are going to find any meaningful difference in speed vs. the FTP route.

Also the line you made in “auto.master” is for pointing to the second file you made. You pointed it to “auto.sshfs.shares” but instead of making that file you made one called “auto.smb.shares”.

#5

Actually I think @hdmkv wanted to use smb and just by accident typed the wrong file name.

@hdmkv in the autofs file you point to the wrong config file. Replace auto.sshfs.shares with auto.smb.shares

1 Like
#12

You’re right, should’ve typed in smb, not sshfs. Thank you sir! I can now see the directory of the share…

Capture

Now the question is how do I actually use this on Vero? How how I add these mounted shares?

#13

As normal, Add Source -> Root File System -> /mnt/xxxxx

1 Like
#15

Awesome, thank you! I’m new to mounting shares :blush:.

#18

So, did several tests w/all my mounted shares and performance is blazing fast. Thanks again. Even the 400Mbps Jellyfish clip plays seemingly effortlessly. Better than NFS, and adding new local content sources/scanning and browsing movies/TV shows are all snappier.

3 Likes