Help With Cloning OSMC SD Card

I searched everywhere and tried 2 different solutions with no success.

I just finished setting up my new Raspberry Pi 3 Kodi machine using the latest image of OSMC. I do not have NOOBS or any other OS installed, just the OSMC image. I used Win32 Disk Imager to image the card initially.

I have all of my settings, video sources, preferences setup to the way I like them. Everything is on a SanDisk Ultra 64GB Class 10 microSD Card. Now I want to clone the card to another microSD card. The exact same microSD card just in case my current card gets fried or corrupted. So if the card corrupts, I can pop in this new one to the existing machine and have no issues. If the Pi somehow fries, I would use this clone on an exact rebuild (if possible).

I know that if I wind up changing the board in the future this will likely not work.

Method 1 - I put the microSD back into my Windows machine. I tried to use Win32 Disk Imager to read it to a new IMG file. I got an error saying it failed.

Method 2 - I tried Acronis True Image. I use this for my Windows PC images. When I selected the card there were 2 partitions. If I selected the first one, the image was going to be 66GB. If I selected both, it would be 112+GB. Naturally, both of them would be too big to write to a new 64GB card.

So now I’m stuck. I have no idea what to do and I assume just copying the files I see in Windows to a new microSD would miss some hidden, essential files?

What’s even stranger is that when I looked at the card’s size in Windows it said I had like 219MB free out of 220+MB. So I’m thinking Windows isn’t reading OSMC card correctly.

Any tips, suggestions or solutions?

Ok, let’s start back to front.
OSMC partitions the card into two partitions.
Partition 1 is 240M big and is formated with FAT32 this partition contains the files necessary to boot the device. Files on this partition as it is FAT32 can be read and changed with windows
Partition 2 is sized with the rest of the space of the SD Card (in your case 64G) this partition is formatted with EXT4 and therefore it’s files can not be read by windows without specific tools.

This doesn’t sound good, maybe the card already has an issue. But what exactly is the error? Any details?

I think you are best of to boot a live Linux USB with the tools like clonezilla, gparted and dd which should make this possible. But be careful the tools can do everything but that also include wiping out your PC. So be careful and better read twice.

While despite GUI solution like above in Linux you could just do dd if=/dev/ of=

Here a clonezilla how to

Yep, that was what I saw. Glad that’s normal then.

I’m an idiot. I wasn’t remembering right what I saw earlier today. I put the Pi microSD back into my PC just now to try again to get the exact error. It was that there was not enough space. Turns out the partition I tried was 57GB free. I switched to one w/ 97 and it’s running right now w/ Win32 Disk Imager.

The process is slow though. Doing the MB/s math, it’ll take 66 minutes if it’s doing the full 64GB to account for the EXT partition. We’ll see how it goes after I’m done.

I appreciate the help and suggestions. If I strike out with this image method, I’ll try what you said in a Linux VM

That obviously would be the best as you also can not damage your PC installation if something goes wrong in the VM

Update - The image creation was a success with Win32 Disk Imager. The resulting image just shy of 64GB. I burned the image to a new SanDisk microSD Class 10 64GB card, and then booted it up in the Pi 3. OSMC worked just fine.

Resurrecting an old thread - I’m trying to do this as well, but Win32DiskImager shows 2x discs on the SD card. Is this the same thing as mentioned in the above thread, and do I just create images of both and then put them on the 2nd SD card?

That’s not 2 discs but 2 partitions

Yes both partitions (boot and root) are needed.

Thanks for clarifying - was confused by my Win10 laptop showing 2 separate drives E:\ and F:.

Sorry to resurrect this again, but I’m trying to do the same thing.

Trouble is, I cannot make an image of my SD card because it does not show in windows at all, not even a drive letter, not even in Disk Management, nothing!

Any ideas?

That would mean either an issue with the SD Card or the Card Reader.
You can always try a Live Linux on USB stick to check that’s not the Windows problem


Tried in multiple card readers on multiple ports.

All I have done with the SD card is setup OSMC on RPi and setup how I like it.
This is with 2 new SD cards too, as neither is visible in Windows.

Strange, then I suggest live Linux USB.

Or if you have 3 cards than can do all on the Pi. Boot from one and copy from one to the other on the Pi directly

I downloaded a free app minitool something or other.

I can now see the partitions are there, and I assume correct. 1. FAT32 316MB 2. EXT4 14.3GB.

I started a copy from the card I have setup to a blank. Strangely, as soon as the partitions were created on the blank card windows popped up saying it was there, but may need a repair. The original card still doesn’t show at all in Windows.

I’ll see what happens when the duplication is finished.

This is normal and expected. Just dismiss the warning and do not tell it to repair or do anything to it in Windows.