Help with compiling a program


My system is:
Device: Rasp Pi 2
Installation media: SDcard
OSMC version: 2015.08-1

I am trying to set up a Firefox Syncserver following outline instructions from Mozilla and detailed instructions from various places including here and here but I’ve run into issues and got stuck. I hope someone can help.

The first problem I had was that “make” could not be found, fixed by “apt-get install make”. Then during make it could not find virtualenv. Odd as I’d installed python-virtualenv. Anyway “apt-get install virtualenv” fixed that and possibly installed python3 as well. Then it complained at not finding arm-linux-gnueabihf-gcc. I took a flyer and installed gcc which appeared to fixe that. Now I am getting the following error:[code]arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wno-error -Wno-error=format-security -fPIC -DWIN32_LEAN_AND_MEAN -I./lib/ -I/usr/include/python2.7 -c ./python/umemcache.cpp -o build/temp.linux-armv7l-2.7/./python/umemcache.o

arm-linux-gnueabihf-gcc: error trying to exec ‘cc1plus’: execvp: No such file or directory

error: command ‘arm-linux-gnueabihf-gcc’ failed with exit status 1[/code]This one has me completely stuck.

Can anyone point me in the right direction?

I have a lot of experience with ClearOS (a RedHat derivative) and yum, but no Debian experience.


I suspect you don’t have all the necessary build tools installed. Try:

sudo apt-get update
sudo apt-get install build-essential

build-essential installs a big bundle of different packages (including gcc, make and so on) that you need for compiling. While you’ve installed a few of those manually there will still be a lot that are missing.

build-essential and git are the only packages I need to install in a fresh OSMC install to start building/compiling.

Brilliant, thanks. That fixed it. I’d already worked out I was missing “make” and “gcc”. I did not know anything about “build-essential”.

Are there any developer docs around?


First and foremost, I’d sudo apt-get install build-essential to get a full set of tools.

It appears that your package is trying to cross-compile.

For documentation you can follow the Debian guidelines for now.


If by developer docs you mean docs for building/compiling software under OSMC, at the moment, not really, however as OSMC is really just a Debian derivative with some custom default configuration and bundled packages, (from our own APT repo) pretty much anything that applies to Debian Jessie applies to OSMC as well.

So any documentation out there for building on Debian Jessie should be applicable - the only difference might be that our default install is a bit “slimmer” than a standard Debian install so there might be some packages you need to install that may already be installed by default on Debian.