Help with decoding issues

Hi all,

I’m getting issues with some videos decoding incorrectly. Green splodges and glitchy video, but the audio is fine.

I’ve made sure I’ve got enough power to run everything, tried overclocking a bit, increased gpu_mem for rpi2 but to no avail.

I’ve read elsewhere that forcing sw decoding might fix the issue, but I’m not sure how to go about this?

any other ideas are welcome, and i’ll try and get any extra info you think would help in figuring this out.


It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC

But my guess is that files are MPEG2 encoded which means you just need to purchase the MPEG2 codec from Raspberry

Here is the media info for 2 example files. First video has green splodges and video stuttering, second just has video stuttering. both have good audio.

Well both files are not MPEG2 so it is not the licence issue.
I assume you already have played them with another machine (e.g. your PC) and they are playing fine there, or?
If that is the case than next step is that you enable debugging play the two movies each for a minute and the upload the logs with grab-logs -A or via MyOSMC

Both play fine on my laptop with VLC, will get the debug info asap.

If it shows a crash then I have no idea why that happened, it hasnt happened before and i’ll try and get to the bottom of that if it becomes a recurrent issue.

In the meantime, can you tell me how you go about forcing SW decoding?

As a first step to avoid issues I would take out the overclocking. While it might not help your decoding issue it could still be an issue leading to overheating and therefore down throttling.

Can you try to copy one of the files not working to the SD Card and try to play it then.

Also you have many of this in your log

[ 191.932843] hub 1-1.3:1.0: hub_port_status failed (err = -71)
[ 191.933007] hub 1-1.3:1.0: hub_port_status failed (err = -71)
[ 191.933171] hub 1-1.3:1.0: hub_port_status failed (err = -71)
[ 191.933474] hub 1-1.3:1.0: hub_port_status failed (err = -71)
[ 191.933635] hub 1-1.3:1.0: hub_port_status failed (err = -71)

Are you sure that your Pi is getting enough power? Can you try unplugging that USB Hub/Device?

In regards to enforcing sw decoding. Those codecs can not be decoded in Hardware so they automatically are decoded in software. The only thing you can play around with is MMAL or OMX as players in Settings -> Video Output.

Pretty sure my pi is getting enough power. I’m running a portable HDD on it and was having issues with my 1A power supply (it wasnt even mounting on osmc). I bought a 2.5A one from raspberry pi and its been mounting and reading fine since and the power light on the pi has been rock steady.

Turning off overclocking and copying to SD card hasnt changed anything either.

Is there an ideal video format to use? if so what is it?

Well not directly and H.264 that you have there is what 99% of people will use for most of their stuff.

I still would say your issue must be some how related to your USB either not enough power or a bad Hub.
So if you unplug all USB devices and play from the SD Card the issue still exists?
If that is the case maybe you can upload a 5 Minute sample of one file that has problems so that we can check on another device.

I’ll try and get that for you soon.

Meanwhile, I can’t seem to find how to change mmal or omx in the settings anywhere. I may be being blind about it but I have looked all over the menus.

Sorry got it wrong, check Settings -> Video -> Acceleration

I didn’t realise there was an advanced settings option.

I am a dunce today.

And tomorrow you will find that there is even an expert mode :slight_smile:
But I would be surprised if this solves your issue

1 Like

say whaaaaaaaat??

I’ve found turning off OMXplayer and MMAL make the green splodges go away. I’m not sure how to cut the video into a sample.